gnu: screen: Update to 4.6.0.

* gnu/packages/screen.scm (screen): Update to 4.6.0.
[source]: Remove patch.
* gnu/packages/patches/screen-fix-info-syntax-error.patch: Delete patch.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Eric Bavier 2017-06-28 22:59:41 -05:00
parent 59b53c4227
commit 57dfc9f86c
No known key found for this signature in database
GPG key ID: FD73CAC719D32566
3 changed files with 3 additions and 52 deletions

View file

@ -984,7 +984,6 @@ dist_patch_DATA = \
%D%/packages/patches/rxvt-unicode-escape-sequences.patch \
%D%/packages/patches/scheme48-tests.patch \
%D%/packages/patches/scotch-test-threading.patch \
%D%/packages/patches/screen-fix-info-syntax-error.patch \
%D%/packages/patches/sdl-libx11-1.6.patch \
%D%/packages/patches/seq24-rename-mutex.patch \
%D%/packages/patches/slim-session.patch \

View file

@ -1,47 +0,0 @@
Fix errors when building the info manual:
[...]
./screen.texinfo:5799: unknown command `suse'
./screen.texinfo:5800: unknown command `deuxchevaux'
make[2]: *** [Makefile:31: screen.info] Error 1
[...]
Patch copied from upstream source repository:
http://git.savannah.gnu.org/cgit/screen.git/commit/?id=a7d2f9e6ecfa794dd0bd3dbeaf6780c88a6f3152
From a7d2f9e6ecfa794dd0bd3dbeaf6780c88a6f3152 Mon Sep 17 00:00:00 2001
From: Andreas Stieger <astieger@suse.com>
Date: Tue, 28 Feb 2017 19:23:01 +0100
Subject: [PATCH] fix texinfo syntax errors
thanks to Andreas Stieger <astieger@suse.com>
---
src/doc/screen.texinfo | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/doc/screen.texinfo b/src/doc/screen.texinfo
index bc4cbae..aadad33 100644
--- a/doc/screen.texinfo
+++ b/doc/screen.texinfo
@@ -5795,7 +5795,7 @@ and Alexander Naumov <alexander_naumov@@opensuse.org>.
Contributors @*
============
-@example
+@verbatim
Thomas Renninger <treen@suse.com>,
Axel Beckert <abe@deuxchevaux.org>,
Ken Beal <kbeal@@amber.ssd.csd.harris.com>,
@@ -5826,7 +5826,7 @@ Contributors @*
Jason Merrill <jason@@jarthur.Claremont.EDU>,
Johannes Zellner <johannes@@zellner.org>,
Pablo Averbuj <pablo@@averbuj.com>.
-@end example
+@end verbatim
@noindent
Version @*
--
cgit v1.0-41-gc330

View file

@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
@ -37,14 +37,13 @@ (define-module (gnu packages screen)
(define-public screen
(package
(name "screen")
(version "4.5.1")
(version "4.6.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/screen/screen-"
version ".tar.gz"))
(patches (search-patches "screen-fix-info-syntax-error.patch"))
(sha256
(base32 "0bbv16gpxrh64sn4bvjy3qjy7jsxjlqlilyysin02fwnvla23nwp"))))
(base32 "1m7yd2bs1i623kk27nfy3qa2mgjp5qjqxwj5qz21r51ycmmp0cwl"))))
(build-system gnu-build-system)
(native-inputs
`(("makeinfo" ,texinfo)))