gnu: valgrind: Enable the arm architecture during configuration.

* gnu/packages/patches/valgrind-enable-arm.patch: New file.
* gnu/packages/valgrind.scm (valgrind)[source]: Add patch.
* gnu-system.am (dist_patch_DATA): Enable patch.
This commit is contained in:
Andreas Enge 2015-10-02 20:59:20 +02:00
parent 2f8fee0623
commit 5768893ad1
3 changed files with 18 additions and 1 deletions

View file

@ -647,6 +647,7 @@ dist_patch_DATA = \
gnu/packages/patches/unzip-remove-build-date.patch \
gnu/packages/patches/util-linux-tests.patch \
gnu/packages/patches/upower-builddir.patch \
gnu/packages/patches/valgrind-enable-arm.patch \
gnu/packages/patches/vpnc-script.patch \
gnu/packages/patches/vtk-mesa-10.patch \
gnu/packages/patches/w3m-fix-compile.patch \

View file

@ -0,0 +1,15 @@
Accept "arm" instead of "armv7" in configure, see
http://valgrind.10908.n7.nabble.com/building-for-arm-td39382.html .
diff -u -r valgrind-3.11.0.orig/configure valgrind-3.11.0/configure
--- valgrind-3.11.0.orig/configure 2015-10-02 20:37:41.915721386 +0200
+++ valgrind-3.11.0/configure 2015-10-02 20:37:54.886746395 +0200
@@ -5607,7 +5607,7 @@
ARCH_MAX="s390x"
;;
- armv7*)
+ arm*)
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: ok (${host_cpu})" >&5
$as_echo "ok (${host_cpu})" >&6; }
ARCH_MAX="arm"

View file

@ -37,7 +37,8 @@ (define-public valgrind
version ".tar.bz2"))
(sha256
(base32
"0hiv871b9bk689mv42mkhp76za78l5773glszfkdbpf1m1qn4fbc"))))
"0hiv871b9bk689mv42mkhp76za78l5773glszfkdbpf1m1qn4fbc"))
(patches (map search-patch '("valgrind-enable-arm.patch")))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-cons-after