gnu: Remove python2-parameterized.

* gnu/packages/check.scm (python2-parameterized): Delete variable.
* gnu/packages/patches/python2-parameterized-docstring-test.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.
This commit is contained in:
Maxim Cournoyer 2022-04-29 17:32:48 -04:00
parent 0837d0aaf1
commit 55fc0947d4
No known key found for this signature in database
GPG key ID: 1260E46482E63562
3 changed files with 0 additions and 30 deletions

View file

@ -1705,7 +1705,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-mox3-python3.6-compat.patch \
%D%/packages/patches/python-typing-inspect-fix.patch \
%D%/packages/patches/python-packaging-test-arch.patch \
%D%/packages/patches/python2-parameterized-docstring-test.patch \
%D%/packages/patches/python-paste-remove-timing-test.patch \
%D%/packages/patches/python-pycrypto-CVE-2013-7459.patch \
%D%/packages/patches/python-pycrypto-time-clock.patch \

View file

@ -818,19 +818,8 @@ (define-public python-parameterized
(description
"Parameterized is a Python library that aims to fix parameterized testing
for every Python test framework. It supports nose, py.test, and unittest.")
(properties `((python2-variant . ,(delay python2-parameterized))))
(license license:bsd-2)))
(define-public python2-parameterized
(let ((base (package-with-python2 (strip-python2-variant
python-parameterized))))
(package/inherit
base
(source
(origin
(inherit (package-source base))
(patches (search-patches "python2-parameterized-docstring-test.patch")))))))
(define-public python-minimock
(package
(name "python-minimock")

View file

@ -1,18 +0,0 @@
Skip unicode docstring test, required when running on Python 2.
See <https://github.com/wolever/parameterized/issues/44>.
--- a/parameterized/test.py
+++ b/parameterized/test.py
@@ -284,11 +284,6 @@
" More" %(foo, )
)
- @parameterized.expand([param("foo")])
- def test_unicode_docstring(self, foo):
- u"""Döcumentation."""
- self._assert_docstring(u"Döcumentation [with foo=%r]." %(foo, ))
-
@parameterized.expand([param("foo", )])
def test_default_values_get_correct_value(self, foo, bar=12):
"""Documentation"""