gnu: emacs-git-email: Fixes build of package.

* gnu/packages/patches/emacs-git-email-missing-parens.patch: New file.
* gnu/packages/emacs-xyz.scm (emacs-git-email)[source]: Use it.
* gnu/local.mk (dist_patch_DATA): Add it.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Niklas Eklund 2022-05-05 13:10:56 +02:00 committed by Ludovic Courtès
parent e48b5484af
commit 51bbcc91b4
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
3 changed files with 30 additions and 0 deletions

View file

@ -1028,6 +1028,7 @@ dist_patch_DATA = \
%D%/packages/patches/elm-compiler-fix-map-key.patch \
%D%/packages/patches/elogind-revert-polkit-detection.patch \
%D%/packages/patches/emacs-exec-path.patch \
%D%/packages/patches/emacs-git-email-missing-parens.patch \
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
%D%/packages/patches/emacs-ignore-empty-xim-styles.patch \
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \

View file

@ -15759,6 +15759,8 @@ (define-public emacs-git-email
(uri (git-reference
(url "https://git.sr.ht/~yoctocell/git-email")
(commit commit)))
(patches
(search-patches "emacs-git-email-missing-parens.patch"))
(file-name (git-file-name name version))
(sha256
(base32 "1lk1yds7idgawnair8l3s72rgjmh80qmy4kl5wrnqvpmjrmdgvnx"))))

View file

@ -0,0 +1,27 @@
From 820ad7eb2e919e3f880bec22bd4f737fa55c4d22 Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Thu, 5 May 2022 12:43:49 +0200
Subject: [PATCH] Fix missing parens in git-email-mu4e.el
The incorrect number of parens in this file lead to Emacs failing to
parse the file.
---
git-email-mu4e.el | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/git-email-mu4e.el b/git-email-mu4e.el
index d5b8770..9220bf9 100644
--- a/git-email-mu4e.el
+++ b/git-email-mu4e.el
@@ -51,7 +51,7 @@ from Lisp, enable the mode if ARG is omitted or nil."
;; built in context feature.
(seq-filter (lambda (header)
(not (eq (car header) 'from)))
- headers)
+ headers))))
(setq git-email-compose-email-function 'message-mail)))
(provide 'git-email-mu4e)
--
2.34.0