gnu: thermald: Update to 1.9.

* gnu/packages/admin.scm (thermald): Update to 1.9.
[source]: Remove patch.
* packages/patches/thermald-make-int-max32-visible.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Tobias Geerinckx-Rice 2019-12-01 02:31:52 +01:00
parent 50db7df4d2
commit 4d441ca174
No known key found for this signature in database
GPG key ID: D889B0F018C5493C
3 changed files with 2 additions and 29 deletions

View file

@ -1391,7 +1391,6 @@ dist_patch_DATA = \
%D%/packages/patches/texi2html-document-encoding.patch \
%D%/packages/patches/texi2html-i18n.patch \
%D%/packages/patches/thefuck-test-environ.patch \
%D%/packages/patches/thermald-make-int-max32-visible.patch \
%D%/packages/patches/tidy-CVE-2015-5522+5523.patch \
%D%/packages/patches/tinyxml-use-stl.patch \
%D%/packages/patches/tipp10-fix-compiling.patch \

View file

@ -3015,7 +3015,7 @@ (define-public nnn
(define-public thermald
(package
(name "thermald")
(version "1.8")
(version "1.9")
(source
(origin
(method git-fetch)
@ -3024,9 +3024,7 @@ (define-public thermald
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32 "1g1l7k8yxj8bl1ysdx8v6anv1s7xk9j072y44gwki70dy48n7j92"))
(patches
(search-patches "thermald-make-int-max32-visible.patch"))))
(base32 "1ajhivl9jifcf12nbk281yayk7666v65m249aclyli0bz1kh8cfs"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags

View file

@ -1,24 +0,0 @@
From 5fb947886bf1e40475edf930fb2b284c24c8cb9a Mon Sep 17 00:00:00 2001
From: Sanel Zukan <karijes@users.sourceforge.net>
Date: Sun, 23 Dec 2018 00:04:34 +0100
Subject: [PATCH] Make sure INT_MAX32 is visible.
---
src/thd_trip_point.h | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/src/thd_trip_point.h b/src/thd_trip_point.h
index 0eedc95..89eb083 100644
--- a/src/thd_trip_point.h
+++ b/src/thd_trip_point.h
@@ -29,6 +29,10 @@
#include "thd_sys_fs.h"
#include "thd_preference.h"
#include "thd_cdev.h"
+
+#define __STDC_LIMIT_MACROS
+#include <stdint.h>
+
#include <time.h>
#include <vector>
#include <algorithm> // std::sort