gnu: emacs-zones: Update to 2019.7.13.

* gnu/packages/emacs-xyz.scm (emacs-zones): Update to 2019.7.13.
[source]: Use GNU ELPA repository instead of GitHub.  Remove unnecessary
patch.
* gnu/packages/patches/emacs-zones-called-interactively.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Apply file deletion.
This commit is contained in:
Nicolas Goaziou 2020-06-06 16:07:14 +02:00
parent 36b5cfdf02
commit 49b4a062f9
No known key found for this signature in database
GPG key ID: DA00B4F048E92F2D
3 changed files with 20 additions and 71 deletions

View file

@ -895,7 +895,6 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-telega-test-env.patch \
%D%/packages/patches/emacs-undohist-ignored.patch \
%D%/packages/patches/emacs-wordnut-require-adaptive-wrap.patch \
%D%/packages/patches/emacs-zones-called-interactively.patch \
%D%/packages/patches/enjarify-setup-py.patch \
%D%/packages/patches/enlightenment-fix-setuid-path.patch \
%D%/packages/patches/erlang-man-path.patch \

View file

@ -9311,33 +9311,26 @@ (define-public emacs-alert
(license license:gpl2+)))
(define-public emacs-zones
(let ((commit "3169815c323966ff8e252b44e3558d6d045243fe")
(revision "2"))
(package
(name "emacs-zones")
(version (git-version "0" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/emacsmirror/zones.git")
(commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
"039msns5596rz0my7fxpanpxwg1lkhpiibm9ppnlzaajx1hszbzl"))
(patches
(search-patches
"emacs-zones-called-interactively.patch"))))
(build-system emacs-build-system)
(home-page "https://www.emacswiki.org/emacs/Zones")
(synopsis "Define and act on multiple zones of buffer text")
(description "Library @file{zones.el} lets you easily define and
subsequently act on multiple zones of buffer text. You can think of this as
enlarging the notion of region. In effect, it can remove the requirement of
target text being a contiguous sequence of characters. A set of buffer zones
is, in effect, a (typically) noncontiguous set of text.")
(license license:gpl3+))))
(package
(name "emacs-zones")
(version "2019.7.13")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"zones-" version ".el"))
(sha256
(base32 "0qp1ba2pkqx9d35g7z8hf8qs2k455krf2a92l4rka3ipsbnmq5k1"))))
(build-system emacs-build-system)
(home-page "https://www.emacswiki.org/emacs/Zones")
(synopsis "Define and act on multiple zones of buffer text")
(description
"Library @file{zones.el} lets you easily define and subsequently act on
multiple zones of buffer text. You can think of this as enlarging the notion
of region. In effect, it can remove the requirement of target text being
a contiguous sequence of characters. A set of buffer zones is, in effect,
a (typically) noncontiguous set of text.")
(license license:gpl3+)))
(define-public emacs-mu4e-alert
(package

View file

@ -1,43 +0,0 @@
From 81603e53ebaae0f0b23c4c52c7dab83e808964ec Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Sun, 17 Mar 2019 01:32:04 +0100
Subject: [PATCH] This patch silences the byte-compiler.
---
zones.el | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/zones.el b/zones.el
index ca88d48..594ea36 100644
--- a/zones.el
+++ b/zones.el
@@ -1075,7 +1075,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
This is a destructive operation. The list structure of the variable
value can be modified."
- (zz-narrow-advice (interactive-p)))
+ (zz-narrow-advice (called-interactively-p 'interactive)))
(defadvice narrow-to-defun (after zz-add-zone--defun activate)
"Push the defun limits to the current `zz-izones-var'.
@@ -1083,7 +1083,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
This is a destructive operation. The list structure of the variable
value can be modified."
- (zz-narrow-advice (interactive-p)))
+ (zz-narrow-advice (called-interactively-p 'interactive)))
;; Call `zz-add-zone' if interactive or `zz-add-zone-anyway-p'.
;;
@@ -1093,7 +1093,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
This is a destructive operation. The list structure of the variable
value can be modified."
- (zz-narrow-advice (interactive-p)))
+ (zz-narrow-advice (called-interactively-p 'interactive)))
;;(@* "General Commands")
--
2.22.0