gnu: guile: Disable unreliable out-of-memory test

* gnu/packages/patches/guile-2.2-skip-oom-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/guile.scm (guile-2.2)[source](patches): Add
  "guile-2.2-skip-oom-test.patch".

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Carl Dong 2019-05-28 15:40:26 +00:00 committed by Ludovic Courtès
parent b644008ca2
commit 44f07d1dc6
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 28 additions and 0 deletions

View File

@ -891,6 +891,7 @@ dist_patch_DATA = \
%D%/packages/patches/gspell-dash-test.patch \
%D%/packages/patches/guile-1.8-cpp-4.5.patch \
%D%/packages/patches/guile-2.2-default-utf8.patch \
%D%/packages/patches/guile-2.2-skip-oom-test.patch \
%D%/packages/patches/guile-default-utf8.patch \
%D%/packages/patches/guile-gdbm-ffi-support-gdbm-1.14.patch \
%D%/packages/patches/guile-linux-syscalls.patch \

View File

@ -228,6 +228,8 @@ without requiring the source code to be rewritten.")
(base32
"07p3g0v2ba2vlfbfidqzlgbhnzdx46wh2rgc5gszq1mjyx5bks6r"))
(modules '((guix build utils)))
(patches (search-patches
"guile-2.2-skip-oom-test.patch"))
;; Remove the pre-built object files. Instead, build everything
;; from source, at the expense of significantly longer build

View File

@ -0,0 +1,25 @@
Skip 'test-out-of-memory', which is unreliable in Guile 2.2.4:
https://bugs.gnu.org/34155
--- a/test-suite/standalone/Makefile.in 1969-12-31 19:00:00.000000000 -0500
+++ b/test-suite/standalone/Makefile.in 2019-05-27 16:44:32.302355990 -0400
@@ -103,7 +103,7 @@
test-scm-c-bind-keyword-arguments$(EXEEXT) \
test-srfi-4$(EXEEXT) $(am__append_6) $(am__EXEEXT_1) \
test-smob-mark$(EXEEXT) test-smob-mark-race$(EXEEXT) \
- test-stack-overflow test-out-of-memory
+ test-stack-overflow
check_PROGRAMS = test-num2integral$(EXEEXT) test-round$(EXEEXT) \
test-foreign-object-c$(EXEEXT) test-list$(EXEEXT) \
test-unwind$(EXEEXT) test-conversion$(EXEEXT) \
@@ -1938,8 +1938,7 @@
test-command-line-encoding test-command-line-encoding2 \
test-language test-guild-compile $(am__append_3) \
test-foreign-object-scm test-fast-slot-ref test-mb-regexp \
- test-use-srfi $(am__append_5) test-stack-overflow \
- test-out-of-memory
+ test-use-srfi $(am__append_5) test-stack-overflow
BUILT_SOURCES = $(am__append_2)
EXTRA_DIST = test-import-order-a.scm test-import-order-b.scm \
test-import-order-c.scm test-import-order-d.scm \