gnu: webkitgtk: Update to 2.40.1 [security fixes].
Fixes CVE-2022-0108, CVE-2022-32885, CVE-2023-27932, CVE-2023-27954, and CVE-2023-28205. * gnu/packages/webkit.scm: Update to 2.40.1. [source]: Remove obsolete patch. * gnu/packages/patches/webkitgtk-libelogind.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Leo Famulari <leo@famulari.name>
This commit is contained in:
parent
3575af7bdc
commit
44905f2795
3 changed files with 3 additions and 43 deletions
|
@ -2007,7 +2007,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/warsow-qfusion-fix-bool-return-type.patch \
|
||||
%D%/packages/patches/wdl-link-libs-and-fix-jnetlib.patch \
|
||||
%D%/packages/patches/webkitgtk-adjust-bubblewrap-paths.patch \
|
||||
%D%/packages/patches/webkitgtk-libelogind.patch \
|
||||
%D%/packages/patches/webrtc-audio-processing-big-endian.patch \
|
||||
%D%/packages/patches/webrtc-for-telegram-desktop-fix-gcc12-cstdint.patch \
|
||||
%D%/packages/patches/websocketpp-fix-for-cmake-3.15.patch \
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
From 8d46803c09edc2b6d4e35c778a3d2f90e5baad0b Mon Sep 17 00:00:00 2001
|
||||
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
||||
Date: Sat, 25 Mar 2023 22:55:16 -0400
|
||||
Subject: [PATCH] Fallback to elogind when systemd is unavailable at build time
|
||||
https://bugs.webkit.org/show_bug.cgi?id=254475
|
||||
|
||||
Reviewed by NOBODY (OOPS!).
|
||||
|
||||
The build system supports elogind, but it only considers the
|
||||
'libsystemd' library name for the pkg-config lookup and not
|
||||
'libelogind'. This change makes the build system fallback to search
|
||||
for libelogind when libsystemd was not found.
|
||||
|
||||
* Source/cmake/FindJournald.cmake [!PC_SYSTEMD_FOUND]: Search for libelogind.
|
||||
---
|
||||
Source/cmake/FindJournald.cmake | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/Source/cmake/FindJournald.cmake b/Source/cmake/FindJournald.cmake
|
||||
index 18dd6b50908c..e0dc9ce1d397 100644
|
||||
--- a/Source/cmake/FindJournald.cmake
|
||||
+++ b/Source/cmake/FindJournald.cmake
|
||||
@@ -55,6 +55,10 @@ find_package(PkgConfig QUIET)
|
||||
|
||||
# libelogind provides compatible pc and header files
|
||||
pkg_check_modules(PC_SYSTEMD QUIET libsystemd)
|
||||
+if (NOT PC_SYSTEMD_FOUND)
|
||||
+ pkg_check_modules(PC_SYSTEMD QUIET libelogind)
|
||||
+endif ()
|
||||
+
|
||||
set(Journald_COMPILE_OPTIONS ${PC_SYSTEMD_CFLAGS_OTHER})
|
||||
set(Journald_VERSION ${PC_SYSTEMD_VERSION})
|
||||
|
||||
|
||||
base-commit: 43ea8744bc6065aad7ae5988e32d31d253905e5f
|
||||
--
|
||||
2.39.2
|
||||
|
|
@ -127,16 +127,15 @@ (define-public wpebackend-fdo
|
|||
(define-public webkitgtk
|
||||
(package
|
||||
(name "webkitgtk") ; webkit2gtk4
|
||||
(version "2.40.0")
|
||||
(version "2.40.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://www.webkitgtk.org/releases/"
|
||||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32 "14xkgamqlshxqw6fcslvw0yzj4y5mvx66b6bn64rwrl9pyhpwq54"))
|
||||
(base32 "1xky3cy4l5k0nj366pk17lrzy0n0k6plks9sy0g1dllc9yc2drb4"))
|
||||
(patches (search-patches
|
||||
"webkitgtk-adjust-bubblewrap-paths.patch"
|
||||
"webkitgtk-libelogind.patch"))))
|
||||
"webkitgtk-adjust-bubblewrap-paths.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(outputs '("out" "doc" "debug"))
|
||||
(arguments
|
||||
|
|
Loading…
Reference in a new issue