gnu: cmake-minimal: Update to 3.24.2.
* gnu/packages/patches/cmake-curl-certificates.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/cmake.scm (cmake-bootstrap): Update to 3.24.2 [source](patches): Use refreshed patch. (cmake)[version, source]: Remove.
This commit is contained in:
parent
2ca34cc3bb
commit
3cf8b3dc57
3 changed files with 3 additions and 62 deletions
|
@ -971,7 +971,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/classpath-miscompilation.patch \
|
||||
%D%/packages/patches/cling-use-shared-library.patch \
|
||||
%D%/packages/patches/clucene-pkgconfig.patch \
|
||||
%D%/packages/patches/cmake-curl-certificates.patch \
|
||||
%D%/packages/patches/cmake-curl-certificates-3.24.patch \
|
||||
%D%/packages/patches/coda-use-system-libs.patch \
|
||||
%D%/packages/patches/collectd-5.11.0-noinstallvar.patch \
|
||||
|
|
|
@ -152,7 +152,7 @@ (define %preserved-third-party-files
|
|||
(define-public cmake-bootstrap
|
||||
(package
|
||||
(name "cmake-bootstrap")
|
||||
(version "3.24.1")
|
||||
(version "3.24.2")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://cmake.org/files/v"
|
||||
|
@ -160,8 +160,8 @@ (define-public cmake-bootstrap
|
|||
"/cmake-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0ax83yfis1n74llqhckrbgzcp82pfwx039xs2dgq06nvlivy4ca9"))
|
||||
(patches (search-patches "cmake-curl-certificates.patch"))))
|
||||
"1ny8y2dzc6fww9gzb1ml0vjpx4kclphjihkxagxigprxdzq2140d"))
|
||||
(patches (search-patches "cmake-curl-certificates-3.24.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
(list
|
||||
|
@ -330,23 +330,6 @@ (define-public cmake
|
|||
(package
|
||||
(inherit cmake-minimal)
|
||||
(name "cmake")
|
||||
(version "3.24.2")
|
||||
(source (origin
|
||||
(inherit (package-source cmake-minimal))
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://cmake.org/files/v"
|
||||
(version-major+minor version)
|
||||
"/cmake-" version ".tar.gz"))
|
||||
(snippet (match (origin-snippet (package-source cmake-minimal))
|
||||
(('begin ('define 'preserved-files ('quote x))
|
||||
rest ...)
|
||||
`(begin (define preserved-files
|
||||
',(cons "Utilities/cmelf" x))
|
||||
,@rest))))
|
||||
(sha256
|
||||
(base32
|
||||
"1ny8y2dzc6fww9gzb1ml0vjpx4kclphjihkxagxigprxdzq2140d"))
|
||||
(patches (search-patches "cmake-curl-certificates-3.24.patch"))))
|
||||
(outputs '("out" "doc"))
|
||||
(arguments
|
||||
(substitute-keyword-arguments (package-arguments cmake-minimal)
|
||||
|
|
|
@ -1,41 +0,0 @@
|
|||
By default commands such as "ctest" would not look for certificates
|
||||
at all: <https://issues.guix.gnu.org/issue/37371>.
|
||||
|
||||
This changes CMake such that commands honor SSL_CERT_FILE and SSL_CERT_DIR
|
||||
as well as /etc/ssl/certs.
|
||||
|
||||
diff --git a/Source/cmCurl.cxx b/Source/cmCurl.cxx
|
||||
index 28ee24dfe9..6b2bb09ff5 100644
|
||||
--- a/Source/cmCurl.cxx
|
||||
+++ b/Source/cmCurl.cxx
|
||||
@@ -2,10 +2,7 @@
|
||||
file Copyright.txt or https://cmake.org/licensing for details. */
|
||||
#include "cmCurl.h"
|
||||
|
||||
-#if !defined(CMAKE_USE_SYSTEM_CURL) && !defined(_WIN32) && \
|
||||
- !defined(__APPLE__) && !defined(CURL_CA_BUNDLE) && !defined(CURL_CA_PATH)
|
||||
# define CMAKE_FIND_CAFILE
|
||||
-#endif
|
||||
#include "cmStringAlgorithms.h"
|
||||
#include "cmSystemTools.h"
|
||||
|
||||
@@ -38,6 +35,19 @@ std::string cmCurlSetCAInfo(::CURL* curl, const std::string& cafile)
|
||||
::CURLcode res = ::curl_easy_setopt(curl, CURLOPT_CAINFO, cafile.c_str());
|
||||
check_curl_result(res, "Unable to set TLS/SSL Verify CAINFO: ");
|
||||
}
|
||||
+
|
||||
+ /* Honor the usual environment variables. */
|
||||
+ else if (cmSystemTools::GetEnv("SSL_CERT_FILE", e)) {
|
||||
+ ::CURLcode res =
|
||||
+ ::curl_easy_setopt(curl, CURLOPT_CAINFO, e.c_str());
|
||||
+ check_curl_result(res, "Unable to set TLS/SSL Verify CAINFO: ");
|
||||
+ }
|
||||
+ else if (cmSystemTools::GetEnv("SSL_CERT_DIR", e)) {
|
||||
+ ::CURLcode res =
|
||||
+ ::curl_easy_setopt(curl, CURLOPT_CAPATH, e.c_str());
|
||||
+ check_curl_result(res, "Unable to set TLS/SSL Verify CAINFO: ");
|
||||
+ }
|
||||
+
|
||||
#ifdef CMAKE_FIND_CAFILE
|
||||
# define CMAKE_CAFILE_FEDORA "/etc/pki/tls/certs/ca-bundle.crt"
|
||||
else if (cmSystemTools::FileExists(CMAKE_CAFILE_FEDORA, true)) {
|
Loading…
Reference in a new issue