gnu: qtbase: Remove obsolete patch.
This patch is no longer needed since 7930cfc989
was merged to core-updates.
* gnu/packages/patches/qtbase-glibc-compat.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/qt.scm (qtbase)[source](patches): Drop it.
This commit is contained in:
parent
f4a5faa9dc
commit
3bd83e6db2
3 changed files with 1 additions and 53 deletions
|
@ -1097,7 +1097,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python-waitress-fix-tests.patch \
|
||||
%D%/packages/patches/qemu-glibc-2.27.patch \
|
||||
%D%/packages/patches/qt4-ldflags.patch \
|
||||
%D%/packages/patches/qtbase-glibc-compat.patch \
|
||||
%D%/packages/patches/qtbase-use-TZDIR.patch \
|
||||
%D%/packages/patches/qtscript-disable-tests.patch \
|
||||
%D%/packages/patches/quagga-reproducible-build.patch \
|
||||
|
|
|
@ -1,50 +0,0 @@
|
|||
Fix qmake build with glibc 2.28.
|
||||
|
||||
Taken from upstream:
|
||||
https://code.qt.io/cgit/qt/qtbase.git/commit/?id=25feee4e061b99edab79503d81f5bd045c6c8e3d
|
||||
|
||||
diff --git a/src/corelib/global/qconfig-bootstrapped.h b/src/corelib/global/qconfig-bootstrapped.h
|
||||
index 3469ebe5e6..c5585ea32a 100644
|
||||
--- a/src/corelib/global/qconfig-bootstrapped.h
|
||||
+++ b/src/corelib/global/qconfig-bootstrapped.h
|
||||
@@ -98,10 +98,18 @@
|
||||
#define QT_NO_QOBJECT
|
||||
#define QT_FEATURE_process -1
|
||||
#define QT_FEATURE_regularexpression -1
|
||||
-#define QT_FEATURE_renameat2 -1
|
||||
+#ifdef __GLIBC_PREREQ
|
||||
+# define QT_FEATURE_renameat2 (__GLIBC_PREREQ(2, 28) ? 1 : -1)
|
||||
+#else
|
||||
+# define QT_FEATURE_renameat2 -1
|
||||
+#endif
|
||||
#define QT_FEATURE_sharedmemory -1
|
||||
#define QT_FEATURE_slog2 -1
|
||||
-#define QT_FEATURE_statx -1
|
||||
+#ifdef __GLIBC_PREREQ
|
||||
+# define QT_FEATURE_statx (__GLIBC_PREREQ(2, 28) ? 1 : -1)
|
||||
+#else
|
||||
+# define QT_FEATURE_statx -1
|
||||
+#endif
|
||||
#define QT_FEATURE_syslog -1
|
||||
#define QT_NO_SYSTEMLOCALE
|
||||
#define QT_FEATURE_systemsemaphore -1
|
||||
diff --git a/src/corelib/io/qfilesystemengine_unix.cpp b/src/corelib/io/qfilesystemengine_unix.cpp
|
||||
index 0c9cdb8667..deb4a9f220 100644
|
||||
--- a/src/corelib/io/qfilesystemengine_unix.cpp
|
||||
+++ b/src/corelib/io/qfilesystemengine_unix.cpp
|
||||
@@ -91,7 +91,6 @@ extern "C" NSString *NSTemporaryDirectory();
|
||||
# include <sys/syscall.h>
|
||||
# include <sys/sendfile.h>
|
||||
# include <linux/fs.h>
|
||||
-# include <linux/stat.h>
|
||||
|
||||
// in case linux/fs.h is too old and doesn't define it:
|
||||
#ifndef FICLONE
|
||||
@@ -112,6 +111,7 @@ static int renameat2(int oldfd, const char *oldpath, int newfd, const char *newp
|
||||
# endif
|
||||
|
||||
# if !QT_CONFIG(statx) && defined(SYS_statx)
|
||||
+# include <linux/stat.h>
|
||||
static int statx(int dirfd, const char *pathname, int flag, unsigned mask, struct statx *statxbuf)
|
||||
{ return syscall(SYS_statx, dirfd, pathname, flag, mask, statxbuf); }
|
||||
# elif !QT_CONFIG(statx) && !defined(SYS_statx)
|
|
@ -508,8 +508,7 @@ (define-public qtbase
|
|||
(base32
|
||||
"01q1rn5rp9biq3z38953z2hgm4nirvp2jfv8wg7isnld8v1yg0b3"))
|
||||
;; Use TZDIR to avoid depending on package "tzdata".
|
||||
(patches (search-patches "qtbase-use-TZDIR.patch"
|
||||
"qtbase-glibc-compat.patch"))
|
||||
(patches (search-patches "qtbase-use-TZDIR.patch"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
;; corelib uses bundled harfbuzz, md4, md5, sha3
|
||||
|
|
Loading…
Reference in a new issue