gnu: libunwind: Update to 1.2.1.
* gnu/packages/libunwind.scm (libunwind): Upate to 1.2.1. [source]: Remove 'libunwind-CVE-2015-3239.patch'. * gnu/packages/patches/libunwind-CVE-2015-3239.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
8fd92e034b
commit
373cda6ac6
3 changed files with 4 additions and 22 deletions
|
@ -811,7 +811,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libtirpc-CVE-2017-8779.patch \
|
||||
%D%/packages/patches/libtorrent-rasterbar-boost-compat.patch \
|
||||
%D%/packages/patches/libtool-skip-tests2.patch \
|
||||
%D%/packages/patches/libunwind-CVE-2015-3239.patch \
|
||||
%D%/packages/patches/libunistring-gnulib-multi-core.patch \
|
||||
%D%/packages/patches/libusb-0.1-disable-tests.patch \
|
||||
%D%/packages/patches/libvpx-CVE-2016-2818.patch \
|
||||
|
|
|
@ -27,18 +27,18 @@ (define-module (gnu packages libunwind)
|
|||
(define-public libunwind
|
||||
(package
|
||||
(name "libunwind")
|
||||
(version "1.1")
|
||||
(version "1.2.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://savannah/libunwind/libunwind-"
|
||||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"16nhx2pahh9d62mvszc88q226q5lwjankij276fxwrm8wb50zzlx"))
|
||||
(patches (search-patches "libunwind-CVE-2015-3239.patch"))))
|
||||
"1jsslwkilwrsj959dc8b479qildawz67r8m4lzxm7glcwa8cngiz"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
;; FIXME: As of glibc 2.17, we get 3 out of 34 test failures.
|
||||
;; FIXME: As of glibc 2.25, we get 1 out of 34 test failures (2 are
|
||||
;; expected to fail).
|
||||
;; Report them upstream.
|
||||
'(#:tests? #f))
|
||||
(home-page "http://www.nongnu.org/libunwind")
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
Copied from Fedora.
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1232265
|
||||
http://pkgs.fedoraproject.org/cgit/libunwind.git/tree/libunwind-1.1-fix-CVE-2015-3239.patch
|
||||
|
||||
diff -up libunwind-1.1/include/dwarf_i.h.CVE20153239 libunwind-1.1/include/dwarf_i.h
|
||||
--- libunwind-1.1/include/dwarf_i.h.CVE20153239 2015-07-10 13:38:36.404996748 -0400
|
||||
+++ libunwind-1.1/include/dwarf_i.h 2015-07-10 13:39:25.050707613 -0400
|
||||
@@ -20,7 +20,7 @@
|
||||
extern const uint8_t dwarf_to_unw_regnum_map[DWARF_REGNUM_MAP_LENGTH];
|
||||
/* REG is evaluated multiple times; it better be side-effects free! */
|
||||
# define dwarf_to_unw_regnum(reg) \
|
||||
- (((reg) <= DWARF_REGNUM_MAP_LENGTH) ? dwarf_to_unw_regnum_map[reg] : 0)
|
||||
+ (((reg) < DWARF_REGNUM_MAP_LENGTH) ? dwarf_to_unw_regnum_map[reg] : 0)
|
||||
#endif
|
||||
|
||||
#ifdef UNW_LOCAL_ONLY
|
Loading…
Reference in a new issue