gnu: emacs: Disable jit compilation.

* gnu/packages/patches/emacs-disable-jit-compilation.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it here.
* gnu/packages/emacs.scm (emacs-minimal)[patches]: Use it here.
This commit is contained in:
Liliana Marie Prikler 2024-02-13 19:30:50 +01:00
parent 35fc3027f3
commit 3621493e4c
No known key found for this signature in database
GPG key ID: 442A84B8C70E2F87
3 changed files with 22 additions and 1 deletions

View file

@ -1112,6 +1112,7 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-all-the-icons-remove-duplicate-rs.patch \
%D%/packages/patches/emacs-deferred-fix-number-of-arguments.patch \
%D%/packages/patches/emacs-elpy-dup-test-name.patch \
%D%/packages/patches/emacs-disable-jit-compilation.patch \
%D%/packages/patches/emacs-exec-path.patch \
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
%D%/packages/patches/emacs-git-email-missing-parens.patch \

View file

@ -108,7 +108,8 @@ (define-public emacs-minimal
(sha256
(base32
"1p3h4sz8da8vhix5140g2qkdy8mz11d7mmvsym5vy847k1428gbx"))
(patches (search-patches "emacs-exec-path.patch"
(patches (search-patches "emacs-disable-jit-compilation.patch"
"emacs-exec-path.patch"
"emacs-fix-scheme-indent-function.patch"
"emacs-native-comp-driver-options.patch"
"emacs-native-comp-fix-filenames.patch"

View file

@ -0,0 +1,19 @@
Index: emacs-29.2/src/comp.c
===================================================================
--- emacs-29.2.orig/src/comp.c
+++ emacs-29.2/src/comp.c
@@ -5648,8 +5648,12 @@ For internal use. */);
doc: /* If non-nil, compile loaded .elc files asynchronously.
After compilation, each function definition is updated to use the
-natively-compiled one. */);
- native_comp_jit_compilation = true;
+natively-compiled one. This variable is enabled by default upstream,
+but disabled in Guix to better make use of precompiled packages.
+Notably, Guix removes the hashes that prevent inadvertent shadowing
+frm the file names of compiled libraries in order to facilitate grafts.
+Enable at your own risk! */);
+ native_comp_jit_compilation = false;
DEFSYM (Qnative_comp_speed, "native-comp-speed");
DEFSYM (Qnative_comp_debug, "native-comp-debug");