gnu: gcc-11: Fix build on powerpc64le.

* gnu/packages/patches/gcc-11-libstdc++-powerpc.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register patch.
* gnu/packages/gcc.scm (make-libstdc++): Apply patch for gcc versions >= 11
and < 12 on ppc64le.

Co-authored-by: Christopher Baines <mail@cbaines.net>
Signed-off-by: Christopher Baines <mail@cbaines.net>
This commit is contained in:
Andreas Enge 2023-04-13 11:46:47 +02:00 committed by Christopher Baines
parent 66b5d33c4f
commit 31dd526e1c
No known key found for this signature in database
GPG key ID: 5E28A33B0B84F577
3 changed files with 39 additions and 2 deletions

View file

@ -1184,6 +1184,7 @@ dist_patch_DATA = \
%D%/packages/patches/gcc-11-libstdc++-hurd-libpthread.patch \
%D%/packages/patches/gcc-12-cross-environment-variables.patch \
%D%/packages/patches/gcc-10-tree-sra-union-handling.patch \
%D%/packages/patches/gcc-11-libstdc++-powerpc.patch \
%D%/packages/patches/gcolor3-update-libportal-usage.patch \
%D%/packages/patches/gd-fix-tests-on-i686.patch \
%D%/packages/patches/gd-brect-bounds.patch \

View file

@ -2,7 +2,7 @@
;;; Copyright © 2012-2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015, 2016, 2017, 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2023 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015-2018, 2020-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Carlos Sánchez de La Lama <csanchezdll@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@ -889,6 +889,15 @@ (define-public (make-libstdc++ gcc)
":")
"\nAM_CXXFLAGS = ")))))))
'())
,@(let ((version (package-version gcc)))
(if (and (target-ppc64le?)
(version>=? version "11")
(not (version>=? version "12")))
`((add-after 'unpack 'patch-powerpc
(lambda* (#:key inputs #:allow-other-keys)
(invoke "patch" "--force" "-p1" "-i"
(assoc-ref inputs "powerpc64le-patch")))))
'()))
;; Force rs6000 (i.e., powerpc) libdir to be /lib and not /lib64.
(add-before 'chdir 'fix-rs6000-libdir
(lambda _
@ -905,7 +914,14 @@ (define-public (make-libstdc++ gcc)
"/include"))))
(outputs '("out" "debug"))
(inputs '())
(native-inputs '())
(native-inputs
`(,@(if (and (target-ppc64le?)
(let ((version (package-version gcc)))
(and
(version>=? version "11")
(not (version>=? version "12")))))
`(("powerpc64le-patch" ,(search-patch "gcc-11-libstdc++-powerpc.patch")))
'())))
(propagated-inputs '())
(synopsis "GNU C++ standard library")))

View file

@ -0,0 +1,20 @@
--- a/libstdc++-v3/src/c++17/floating_from_chars.cc
+++ b/libstdc++-v3/src/c++17/floating_from_chars.cc
@@ -495,10 +495,16 @@
from_chars(const char* first, const char* last, __ieee128& value,
chars_format fmt) noexcept
{
+ errc ec = errc::invalid_argument;
+#if _GLIBCXX_USE_CXX11_ABI
buffer_resource mr;
pmr::string buf(&mr);
+#else
+ string buf;
+ if (!reserve_string(buf))
+ return make_result(first, 0, {}, ec);
+#endif
size_t len = 0;
- errc ec = errc::invalid_argument;
__try
{
if (const char* pat = pattern(first, last, fmt, buf)) [[likely]]