gnu: guile-next: Update to 3.0.2.

* gnu/packages/guile.scm (guile-3.0): Update to 3.0.2.
* gnu/packages/patches/guile-3.0-crash.patch: Remove.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Ludovic Courtès 2020-03-27 18:12:31 +01:00
parent eb5341c235
commit 3139739802
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
3 changed files with 2 additions and 23 deletions

View file

@ -991,7 +991,6 @@ dist_patch_DATA = \
%D%/packages/patches/guile-1.8-cpp-4.5.patch \
%D%/packages/patches/guile-2.2-default-utf8.patch \
%D%/packages/patches/guile-2.2-skip-oom-test.patch \
%D%/packages/patches/guile-3.0-crash.patch \
%D%/packages/patches/guile-default-utf8.patch \
%D%/packages/patches/guile-gdbm-ffi-support-gdbm-1.14.patch \
%D%/packages/patches/guile-linux-syscalls.patch \

View file

@ -292,17 +292,14 @@ (define-public guile-3.0
(package
(inherit guile-2.2)
(name "guile-next") ;to be renamed to "guile"
(version "3.0.1")
(version "3.0.2")
(source (origin
(inherit (package-source guile-2.2))
(uri (string-append "mirror://gnu/guile/guile-"
version ".tar.xz"))
(sha256
(base32
"1jakps3127h8g69ixgb4zwc8v2g29dmwql1vi3pwg30kzp8fm5nn"))
(patches
(append (search-patches "guile-3.0-crash.patch")
(origin-patches (package-source guile-2.2))))))
"12lziar4j27j9whqp2n18427q45y9ghq7gdd8lqhmj1k0lr7vi2k"))))
(native-search-paths
(list (search-path-specification
(variable "GUILE_LOAD_PATH")

View file

@ -1,17 +0,0 @@
Fix crash due to: <https://issues.guix.gnu.org/issue/39266>.
diff --git a/libguile/struct.c b/libguile/struct.c
index 3dbcc71d4..ddcbe46d2 100644
--- a/libguile/struct.c
+++ b/libguile/struct.c
@@ -139,7 +139,9 @@ set_vtable_access_fields (SCM vtable)
nfields = len / 2;
bitmask_size = (nfields + 31U) / 32U;
- unboxed_fields = scm_gc_malloc_pointerless (bitmask_size, "unboxed fields");
+ unboxed_fields =
+ scm_gc_malloc_pointerless (bitmask_size * sizeof (*unboxed_fields),
+ "unboxed fields");
memset (unboxed_fields, 0, bitmask_size * sizeof(*unboxed_fields));
/* Update FLAGS according to LAYOUT. */