gnu: guile-static: Use Linux syscalls only on Linux-based systems.
* gnu/packages/patches/guile-linux-syscalls.patch: Use Linux syscalls only on Linux-based systems.
This commit is contained in:
parent
f8badf151b
commit
30347caae7
1 changed files with 5 additions and 1 deletions
|
@ -7,12 +7,13 @@ diff --git a/libguile/posix.c b/libguile/posix.c
|
||||||
index 324f21b..cbee94d 100644
|
index 324f21b..cbee94d 100644
|
||||||
--- a/libguile/posix.c
|
--- a/libguile/posix.c
|
||||||
+++ b/libguile/posix.c
|
+++ b/libguile/posix.c
|
||||||
@@ -2286,6 +2286,261 @@ scm_init_popen (void)
|
@@ -2245,6 +2245,263 @@ scm_init_popen (void)
|
||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
+
|
+
|
||||||
+/* Linux! */
|
+/* Linux! */
|
||||||
|
+#ifdef __linux__
|
||||||
+
|
+
|
||||||
+#include <sys/mount.h>
|
+#include <sys/mount.h>
|
||||||
+#include "libguile/foreign.h"
|
+#include "libguile/foreign.h"
|
||||||
|
@ -265,7 +266,10 @@ index 324f21b..cbee94d 100644
|
||||||
+ return scm_from_short (ifr.ifr_flags);
|
+ return scm_from_short (ifr.ifr_flags);
|
||||||
+}
|
+}
|
||||||
+#undef FUNC_NAME
|
+#undef FUNC_NAME
|
||||||
|
+#endif
|
||||||
+
|
+
|
||||||
void
|
void
|
||||||
scm_init_posix ()
|
scm_init_posix ()
|
||||||
{
|
{
|
||||||
|
--
|
||||||
|
2.4.1
|
||||||
|
|
Loading…
Reference in a new issue