gnu: python-docopt: Fix test suite for pytest-6.
* gnu/packages/python-xyz.scm (python-docopt)[source]: Add patch. * gnu/packages/patches/python-docopt-pytest6-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
This commit is contained in:
parent
2ea947fb7d
commit
23b9dadc1d
3 changed files with 32 additions and 1 deletions
|
@ -1600,6 +1600,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python-cross-compile.patch \
|
||||
%D%/packages/patches/python2-larch-coverage-4.0a6-compatibility.patch \
|
||||
%D%/packages/patches/python-configobj-setuptools.patch \
|
||||
%D%/packages/patches/python-docopt-pytest6-compat.patch \
|
||||
%D%/packages/patches/python-flask-restful-werkzeug-compat.patch \
|
||||
%D%/packages/patches/python-keras-integration-test.patch \
|
||||
%D%/packages/patches/python-pep8-stdlib-tokenize-compat.patch \
|
||||
|
|
29
gnu/packages/patches/python-docopt-pytest6-compat.patch
Normal file
29
gnu/packages/patches/python-docopt-pytest6-compat.patch
Normal file
|
@ -0,0 +1,29 @@
|
|||
https://sources.debian.org/data/main/d/docopt/0.6.2-3/debian/patches/pytest6
|
||||
|
||||
From: Michael R. Crusoe <crusoe@debian.org>
|
||||
Subject: fix for pytest 6.x comptability
|
||||
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=979285
|
||||
|
||||
--- docopt.orig/conftest.py
|
||||
+++ docopt/conftest.py
|
||||
@@ -11,6 +11,8 @@
|
||||
|
||||
def pytest_collect_file(path, parent):
|
||||
if path.ext == ".docopt" and path.basename.startswith("test"):
|
||||
+ if hasattr(DocoptTestFile, "from_parent"):
|
||||
+ return DocoptTestFile.from_parent(parent, fspath=path)
|
||||
return DocoptTestFile(path, parent)
|
||||
|
||||
|
||||
@@ -41,7 +43,10 @@
|
||||
for name, doc, cases in parse_test(raw):
|
||||
name = self.fspath.purebasename
|
||||
for case in cases:
|
||||
- yield DocoptTestItem("%s(%d)" % (name, index), self, doc, case)
|
||||
+ if hasattr(DocoptTestItem, "from_parent"):
|
||||
+ yield DocoptTestItem.from_parent(self, name="%s(%d)" % (name, index), doc=doc, case=case)
|
||||
+ else:
|
||||
+ yield DocoptTestItem("%s(%d)" % (name, index), self, doc, case)
|
||||
index += 1
|
||||
|
||||
|
|
@ -11563,7 +11563,8 @@ (define-public python-docopt
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"0aad9gbswnnhssin2q0m5lmpm0ahyf80ahs2zjigbn5y7fvljnd0"))))
|
||||
"0aad9gbswnnhssin2q0m5lmpm0ahyf80ahs2zjigbn5y7fvljnd0"))
|
||||
(patches (search-patches "python-docopt-pytest6-compat.patch"))))
|
||||
(build-system python-build-system)
|
||||
(native-inputs
|
||||
`(("python-pytest" ,python-pytest)))
|
||||
|
|
Loading…
Reference in a new issue