gnu: pciutils: Build fixes for the Hurd.

* gnu/packages/linux.scm (kmod)[supported-systems]: Remove the Hurd.
* gnu/packages/patches/pciutils-hurd-configure.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/pciutils.scm (pciutils): Use it.
[inputs]: Include kmod only for supported systems.
This commit is contained in:
Jan Nieuwenhuizen 2020-03-07 04:05:02 -05:00
parent 1a9b3faaf2
commit 22ee720979
No known key found for this signature in database
GPG key ID: F3C1A0D9C1D65273
4 changed files with 46 additions and 1 deletions

View file

@ -1281,6 +1281,7 @@ dist_patch_DATA = \
%D%/packages/patches/p7zip-remove-unused-code.patch \
%D%/packages/patches/pam-mount-luks2-support.patch \
%D%/packages/patches/pango-skip-libthai-test.patch \
%D%/packages/patches/pciutils-hurd-configure.patch \
%D%/packages/patches/sdl-pango-api_additions.patch \
%D%/packages/patches/sdl-pango-blit_overflow.patch \
%D%/packages/patches/sdl-pango-fillrect_crash.patch \

View file

@ -2784,6 +2784,7 @@ (define-public kmod
'("insmod" "rmmod" "lsmod" "modprobe"
"modinfo" "depmod"))
#t))))))
(supported-systems (delete "i586-gnu" %supported-systems))
(home-page "https://www.kernel.org/")
(synopsis "Kernel module tools")
(description "Kmod is a set of tools to handle common tasks with Linux

View file

@ -0,0 +1,35 @@
Add ability to detect GNU/Hurd when configuring.
Adapted from https://git.hadrons.org/cgit/debian/pkgs/pciutils.git/tree/debian/patches/00-configure-hurd.patch
From e39a3af22501234a91cf28e8c57b45f9379f9101 Mon Sep 17 00:00:00 2001
From: Damien Zammit <damien@zamaudio.com>
Date: Fri, 26 Oct 2018 09:24:04 -0400
Subject: [PATCH 2/2] Add ability to detect GNU/Hurd when configuring
---
lib/configure | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
--- a/lib/configure
+++ b/lib/configure
@@ -25,7 +25,7 @@ if [ -z "$HOST" ] ; then
proc=`/usr/sbin/lsdev -C -c processor -S available -F name | head -1`
cpu=`/usr/sbin/lsattr -F value -l $proc -a type | sed 's/_.*//'`
else
- cpu=`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/;s/^BePC$/i386/;s/^BeMac$/powerpc/;s/^BeBox$/powerpc/'`
+ cpu=`uname -m | sed 's/^i.86-AT386/i386/;s/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/;s/^BePC$/i386/;s/^BeMac$/powerpc/;s/^BeBox$/powerpc/'`
fi
if [ "$sys" = "DragonFly" ]
then
@@ -39,6 +39,10 @@ if [ -z "$HOST" ] ; then
then
sys=cygwin
fi
+ if [ "$sys" = "GNU" ]
+ then
+ sys=gnu
+ fi
HOST=${3:-$cpu-$sys}
fi
[ -n "$RELEASE" ] && rel="${RELEASE}"

View file

@ -3,6 +3,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@ -25,8 +26,10 @@ (define-module (gnu packages pciutils)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages hurd)
#:use-module (gnu packages linux)
#:use-module (gnu packages base))
@ -39,6 +42,7 @@ (define-public pciutils
(uri (string-append
"mirror://kernel.org/software/utils/pciutils/pciutils-"
version ".tar.xz"))
(patches (search-patches "pciutils-hurd-configure.patch"))
(sha256
(base32
"0mb0f2phdcmp4kfiqsszn2k6nlln0w160ffzrjjv4bbfjwrgfzzn"))))
@ -100,7 +104,11 @@ (define-public pciutils
`(("which" ,which)
("pkg-config" ,pkg-config)))
(inputs
`(("kmod" ,kmod)
`(,@(if (member (or (%current-target-system)
(%current-system))
(package-supported-systems kmod))
`(("kmod" ,kmod))
'())
("zlib" ,zlib)))
(home-page "https://mj.ucw.cz/sw/pciutils/")
(synopsis "Programs for inspecting and manipulating PCI devices")