gnu: perl-io-socket-ssl: Update to 2.068.

* gnu/packages/patches/perl-io-socket-ssl-openssl-1.0.2f-fix.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/web.scm (perl-io-socket-ssl): Update to 2.068.
[source](patches): Remove.
This commit is contained in:
Marius Bakke 2020-12-20 17:16:39 +01:00
parent 7405593222
commit 2191d88d1b
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
3 changed files with 2 additions and 38 deletions

View file

@ -1449,7 +1449,6 @@ dist_patch_DATA = \
%D%/packages/patches/perl-autosplit-default-time.patch \
%D%/packages/patches/perl-cross.patch \
%D%/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch \
%D%/packages/patches/perl-io-socket-ssl-openssl-1.0.2f-fix.patch \
%D%/packages/patches/perl-net-amazon-s3-moose-warning.patch \
%D%/packages/patches/perl-net-dns-resolver-programmable-fix.patch \
%D%/packages/patches/perl-no-sys-dirs.patch \

View file

@ -1,33 +0,0 @@
Work around a problem arising from the update to OpenSSL 1.0.2f, based on the
following upstream commit:
https://github.com/noxxi/p5-io-socket-ssl/commit/6e23ee4a433f83f1065bd2467255eba5ee9b1ddd
Attempting to update to IO-Socket-SSL-2.023, which includes this commit,
caused other test failures. See:
https://lists.gnu.org/archive/html/guix-devel/2016-01/msg01032.html
Description from the upstream commit:
OpenSSL 1.0.2f changed the behavior of SSL shutdown in case the TLS connection
was not fully established (commit: f73c737c7ac908c5d6407c419769123392a3b0a9).
This somehow resulted in Net::SSLeay::shutdown returning 0 (i.e. keep trying)
which caused an endless loop. It will now ignore this result in case the TLS
connection was not yet established and consider the TLS connection closed
instead.
--- IO-Socket-SSL-2.002/lib/IO/Socket/SSL.pm.orig 2014-10-21 16:51:16.000000000 -0400
+++ IO-Socket-SSL-2.002/lib/IO/Socket/SSL.pm 2016-01-31 15:07:14.971099894 -0500
@@ -1213,6 +1213,11 @@
# shutdown complete
last;
}
+ if ((${*$self}{'_SSL_opened'}||0) <= 0) {
+ # not really open, thus don't expect shutdown to return
+ # something meaningful
+ last;
+ }
# initiate or complete shutdown
local $SIG{PIPE} = 'IGNORE';

View file

@ -3669,16 +3669,14 @@ (define-public perl-io-socket-ip
(define-public perl-io-socket-ssl
(package
(name "perl-io-socket-ssl")
(version "2.066")
(version "2.068")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/S/SU/SULLR/"
"IO-Socket-SSL-" version ".tar.gz"))
(sha256
(base32
"1kgbws7dwp2hh16qid7169dfkhmcwg7dz9ffbm6k0id5h53hciqd"))
(patches (search-patches
"perl-io-socket-ssl-openssl-1.0.2f-fix.patch"))))
"1ycgzg1l7p07y5wc0vzgnj122vm51p5aqpi4s56pp0piaq0gq824"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-net-ssleay" ,perl-net-ssleay)