gnu: Remove rust-shell2batch-0.4.

* gnu/packages/crates-io.scm (rust-shell2batch-0.4): Delete variable.
* gnu/packages/patches/rust-shell2batch-lint-fix.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Efraim Flashner 2022-10-24 13:53:53 +03:00
parent 9f310ab6ca
commit 200405c490
No known key found for this signature in database
GPG key ID: 41AAE7DCCA3D8351
3 changed files with 0 additions and 50 deletions

View file

@ -1814,7 +1814,6 @@ dist_patch_DATA = \
%D%/packages/patches/rust-nettle-disable-vendor.patch \
%D%/packages/patches/rust-nettle-sys-disable-vendor.patch \
%D%/packages/patches/rust-openssl-sys-no-vendor.patch \
%D%/packages/patches/rust-shell2batch-lint-fix.patch \
%D%/packages/patches/rust-wl-clipboard-rs-newer-wl.patch \
%D%/packages/patches/sbc-fix-build-non-x86.patch \
%D%/packages/patches/sbcl-aserve-add-HTML-5-elements.patch \

View file

@ -69115,30 +69115,6 @@ (define-public rust-xi-unicode-0.3
including a line breaking iterator.")
(license license:asl2.0)))
(define-public rust-shell2batch-0.4
(package
(name "rust-shell2batch")
(version "0.4.2")
(source
(origin
(method url-fetch)
(uri (crate-uri "shell2batch" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "0r9zfhxmqnrnyk7g590333szfpsjijs2wfwy7ish240w6pp54nhq"))
;; https://github.com/sagiegurari/shell2batch/issues/17
(patches (search-patches "rust-shell2batch-lint-fix.patch"))))
(build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs (("rust-regex" ,rust-regex-1))))
(home-page "https://github.com/sagiegurari/shell2batch")
(synopsis "Basic shell scripts to windows batch scripts conversion")
(description "While it is not really possible to take every shell script
and automatically convert it to a windows batch file, this library provides a
way to convert simple shell commands to windows batch commands.")
(license license:asl2.0)))
(define-public rust-enquote-1
(package
(name "rust-enquote")

View file

@ -1,25 +0,0 @@
Resolves the following error that was most likely introduced in new version of
rust as this package is from 2019:
error: unnecessary parentheses around type
--> src/converter.rs:108:61
|
108 | fn add_arguments(arguments: &str, additional_arguments: Vec<(String)>, pre: bool) -> String {
| ^^^^^^^^ help: remove these parentheses
Reported upstream at https://github.com/sagiegurari/shell2batch/issues/17.
diff --git a/src/converter.rs b/src/converter.rs
index fc87d68..af309d2 100644
--- a/src/converter.rs
+++ b/src/converter.rs
@@ -105,7 +105,7 @@ fn replace_vars(arguments: &str) -> String {
updated_arguments
}
-fn add_arguments(arguments: &str, additional_arguments: Vec<(String)>, pre: bool) -> String {
+fn add_arguments(arguments: &str, additional_arguments: Vec<String>, pre: bool) -> String {
let mut windows_arguments = if pre {
"".to_string()
} else {