gnu: randomjungle: Do not build static binaries.

* gnu/packages/patches/randomjungle-disable-static-build.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/machine-learning.scm (randomjungle)[source](patches): Add it.
[arguments]: Add "--disable-static" to #:configure-flags.
This commit is contained in:
Marius Bakke 2018-11-25 20:36:44 +01:00
parent 18142e23e8
commit 1e92d311c3
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 18 additions and 1 deletions

View File

@ -1115,6 +1115,7 @@ dist_patch_DATA = \
%D%/packages/patches/quilt-compat-getopt-fix-second-separator.patch \
%D%/packages/patches/quilt-compat-getopt-fix-option-with-nondigit-param.patch \
%D%/packages/patches/qtwebkit-pbutils-include.patch \
%D%/packages/patches/randomjungle-disable-static-build.patch \
%D%/packages/patches/rapicorn-isnan.patch \
%D%/packages/patches/raptor2-heap-overflow.patch \
%D%/packages/patches/ratpoison-shell.patch \

View File

@ -333,13 +333,15 @@ algorithm.")
(uri (string-append
"http://www.imbs-luebeck.de/imbs/sites/default/files/u59/"
"randomjungle-" version ".tar_.gz"))
(patches (search-patches "randomjungle-disable-static-build.patch"))
(sha256
(base32
"12c8rf30cla71swx2mf4ww9mfd8jbdw5lnxd7dxhyw1ygrvg6y4w"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
(list (string-append "--with-boost="
(list "--disable-static"
(string-append "--with-boost="
(assoc-ref %build-inputs "boost")))
#:phases
(modify-phases %standard-phases

View File

@ -0,0 +1,14 @@
Drop build time dependency on the static executables.
--- a/src/Makefile.in 2018-11-25 20:27:10.691508925 +0100
+++ b/src/Makefile.in 2018-11-25 20:27:43.565631413 +0100
@@ -34,8 +34,7 @@
POST_UNINSTALL = :
build_triplet = @build@
host_triplet = @host@
-bin_PROGRAMS = rjungle$(EXEEXT) rjungle_static$(EXEEXT) \
- rjunglesparse$(EXEEXT) rjunglesparse_static$(EXEEXT)
+bin_PROGRAMS = rjungle$(EXEEXT) rjunglesparse$(EXEEXT)
subdir = src
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4