gnu: libtool and libltdl: Update to 2.4.7.

* gnu/packages/autotools.scm (libtool, libltdl): Update to 2.4.7.
[arguments]: Remove trailing #t from phases. Remove unnecessary file
field from find-files.
(libltdl)[arguments]: Remove trailing #t.
* gnu/packages/patches/libtool-skip-tests2.patch: Update patch.
This commit is contained in:
Efraim Flashner 2022-05-26 20:50:05 +03:00
parent 3acb615a38
commit 1da2834720
No known key found for this signature in database
GPG key ID: 41AAE7DCCA3D8351
2 changed files with 10 additions and 12 deletions

View file

@ -6,7 +6,7 @@
;;; Copyright © 2015, 2017, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2017, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2019, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
@ -451,14 +451,14 @@ (define-public automake-1.16.5
(define-public libtool
(package
(name "libtool")
(version "2.4.6")
(version "2.4.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/libtool/libtool-"
version ".tar.xz"))
(sha256
(base32
"0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))
"0pb3l4x37k6fj1lwnpzws55gi3pxl0hx56jm4bzmbrkw0mzj2zsg"))
(patches (search-patches "libtool-skip-tests2.patch"))))
(build-system gnu-build-system)
(propagated-inputs (list m4))
@ -495,8 +495,7 @@ (define-public libtool
(let ((bash (assoc-ref (or native-inputs inputs) "bash")))
(substitute* "tests/testsuite"
(("/bin/sh")
(string-append bash "/bin/sh")))
#t)))
(string-append bash "/bin/sh"))))))
;; These files may be copied into source trees by libtoolize,
;; therefore they must not point to store file names that would be
;; leaked with tarballs generated by make dist.
@ -508,8 +507,7 @@ (define-public libtool
(format #t "restoring shebang on `~a'~%" file)
(substitute* file
(("^#!.*/bin/sh") "#!/bin/sh")))
(find-files dir ".*"))
#t))))))
(find-files dir))))))))
(synopsis "Generic shared library support tools")
(description
@ -573,20 +571,20 @@ (define-public libltdl
;; Libtool's extensive test suite isn't run.
(package
(name "libltdl")
(version "2.4.6")
(version "2.4.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/libtool/libtool-"
version ".tar.xz"))
(sha256
(base32
"0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))))
"0pb3l4x37k6fj1lwnpzws55gi3pxl0hx56jm4bzmbrkw0mzj2zsg"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--enable-ltdl-install") ;really install it
#:phases (modify-phases %standard-phases
(add-before 'configure 'change-directory
(lambda _ (chdir "libltdl") #t)))))
(lambda _ (chdir "libltdl"))))))
(synopsis "System-independent dlopen wrapper of GNU libtool")
(description (package-description libtool))

View file

@ -16,7 +16,7 @@ Skip the nopic test on ARM, MIPS and RISC-V systems.
@@ -8741,7 +8741,7 @@
{ set +x
$as_echo "$at_srcdir/demo.at:535: case \$host in
$as_echo "$at_srcdir/demo.at:513: case \$host in
-hppa*|x86_64*|s390*)
+hppa*|x86_64*|s390*|arm*|mips*|riscv*)
# These hosts cannot use non-PIC shared libs
@ -24,7 +24,7 @@ Skip the nopic test on ARM, MIPS and RISC-V systems.
*-solaris*|*-sunos*)
@@ -8766,7 +8766,7 @@
"
at_fn_check_prepare_notrace 'a `...` command substitution' "demo.at:535"
at_fn_check_prepare_notrace 'a `...` command substitution' "demo.at:513"
( $at_check_trace; case $host in
-hppa*|x86_64*|s390*)
+hppa*|x86_64*|s390*|arm*|mips*|riscv*)