gnu: jami-libclient: Properly return the list of audio managers.

* gnu/packages/patches/jami-libclient-audio-managers.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/jami.scm (jami)[source]: Move all patches to...
(%jami-sources): here and add the newly added patch.
This commit is contained in:
Maxim Cournoyer 2022-01-27 13:57:54 -05:00
parent 95a74533f1
commit 1916d6df6f
No known key found for this signature in database
GPG key ID: 1260E46482E63562
3 changed files with 29 additions and 5 deletions

View file

@ -1301,6 +1301,7 @@ dist_patch_DATA = \
%D%/packages/patches/jami-fix-crash-on-quit.patch \
%D%/packages/patches/jami-images-loading.patch \
%D%/packages/patches/jami-memory-usage.patch \
%D%/packages/patches/jami-libclient-audio-managers.patch \
%D%/packages/patches/jamvm-1.5.1-aarch64-support.patch \
%D%/packages/patches/jamvm-1.5.1-armv7-support.patch \
%D%/packages/patches/jamvm-2.0.0-aarch64-support.patch \

View file

@ -86,6 +86,10 @@ (define %jami-sources
"client-ios"
"client-macosx"
"client-uwp"))))
(patches (search-patches "jami-libclient-audio-managers.patch"
"jami-fix-crash-on-quit.patch"
"jami-images-loading.patch"
"jami-memory-usage.patch"))
(sha256
(base32
"12h4a0nj3gh05w64gkywrrb64agrhn6y3q4b9cqnhvr1vdkzlj0h"))))
@ -566,11 +570,7 @@ (define-public jami
(package
(name "jami")
(version %jami-version)
(source (origin
(inherit %jami-sources)
(patches (search-patches "jami-fix-crash-on-quit.patch"
"jami-images-loading.patch"
"jami-memory-usage.patch"))))
(source %jami-sources)
(build-system qt-build-system)
(outputs '("out" "debug"))
(arguments

View file

@ -0,0 +1,23 @@
From f5e4619d02526d961c14012a6cae1a091aa149d4 Mon Sep 17 00:00:00 2001
From: Sébastien Blin <sebastien.blin@savoirfairelinux.com>
Date: Thu, 27 Jan 2022 13:48:32 -0500
Subject: [PATCH] misc: link getSupportedAudioManagers
q
Change-Id: I897e49cd131d3cbffef9fb1d5c9be3c0bc9bcb3f
GitLab: #495
---
diff --git a/lrc/src/qtwrapper/configurationmanager_wrap.h b/lrc/src/qtwrapper/configurationmanager_wrap.h
index a680138..2807f8a 100644
--- a/lrc/src/qtwrapper/configurationmanager_wrap.h
+++ b/lrc/src/qtwrapper/configurationmanager_wrap.h
@@ -526,8 +526,7 @@
QStringList getSupportedAudioManagers()
{
- QStringList temp;
- return temp;
+ return convertStringList(DRing::getSupportedAudioManagers());
}
QStringList getSupportedTlsMethod()