gnu: evolution-data-server: Update to 3.34.2.

* gnu/packages/gnome.scm (evolution-data-server): Update to 3.34.2.
[arguments]: Adjust 'disable-failing-tests' phase.
* gnu/packages/patches/evolution-data-server-libical-compat.patch: Update patch.

(cherry picked from commit 3febbdc800)
This commit is contained in:
Kei Kebreau 2019-12-17 11:01:23 -05:00
parent 462d3416a8
commit 162048be3b
No known key found for this signature in database
GPG key ID: E6A5EE3C19467A0D
2 changed files with 10 additions and 17 deletions

View file

@ -6155,7 +6155,7 @@ (define-public gnome-online-accounts
(define-public evolution-data-server
(package
(name "evolution-data-server")
(version "3.32.4")
(version "3.34.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@ -6165,7 +6165,7 @@ (define-public evolution-data-server
"evolution-data-server-libical-compat.patch"))
(sha256
(base32
"0zsc9xwy6ixk3x0dx69ax5isrdw8qxjdxg2i5fr95s40nss7rxl3"))))
"16z85y6hhazcrp5ngw47w4x9r0j8zrj7awv5im58hhp0xs19zf1y"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
@ -6192,13 +6192,6 @@ (define-public evolution-data-server
(delete-file-recursively "tests/book-migration")
(substitute* "tests/CMakeLists.txt"
(("add_subdirectory\\(book-migration\\)") ""))
;; tests/libebook/client/test-book-client-view-operations:8077):
;; e-data-server-WARNING **:
;; (src/libedataserver/e-source-registry.c:264):thread_closure_free:
;; runtime check failed:
;; (!g_main_context_pending (closure->main_context))
(substitute* "tests/libebook/client/CMakeLists.txt"
(("test-book-client-view-operations") ""))
#t))
(add-after 'unpack 'patch-paths
(lambda _

View file

@ -8,29 +8,29 @@ Adapted from upstream:
https://gitlab.gnome.org/GNOME/evolution-data-server/commit/77384ab552c19bf374dbeda53dc37f98d07bd4ec
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e16b8b225..b3c881967 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -108,7 +108,7 @@
@@ -111,7 +111,7 @@ add_definitions(-DSOUP_VERSION_MIN_REQUIRED=${soup_encoded_version})
set(gcr_minimum_version 3.4)
set(libgdata_minimum_version 0.15.1)
-set(libical_minimum_version 2.0)
+set(libical_minimum_version 3.0.7)
-set(libical_glib_minimum_version 3.0.5)
+set(libical_glib_minimum_version 3.0.7)
set(libsecret_minimum_version 0.5)
set(libxml_minimum_version 2.0.0)
set(sqlite_minimum_version 3.7.17)
diff --git a/src/calendar/libedata-cal/e-cal-meta-backend.c b/src/calendar/libedata-cal/e-cal-meta-backend.c
index 7501f2a43dcc3af91e93e89751caf76e77c2ac23..93f4806ba2c5193f746e9fae5bf74d08ad05f8bf 100644
index 7501f2a43..93f4806ba 100644
--- a/src/calendar/libedata-cal/e-cal-meta-backend.c
+++ b/src/calendar/libedata-cal/e-cal-meta-backend.c
@@ -3958,9 +3958,8 @@
@@ -4067,8 +4067,7 @@ e_cal_meta_backend_inline_local_attachments_sync (ECalMetaBackend *meta_backend,
gchar *base64;
base64 = g_base64_encode ((const guchar *) content, len);
- new_attach = icalattach_new_from_data (base64, NULL, NULL);
+ new_attach = icalattach_new_from_data (base64, (GFunc) g_free, NULL);
- new_attach = i_cal_attach_new_from_data (base64, NULL, NULL);
+ new_attach = i_cal_attach_new_from_data (base64, (GFunc) g_free, NULL);
g_free (content);
- g_free (base64);
ecmb_remove_all_but_filename_parameter (prop);