gnu: calibre: Remove unrar test.

* gnu/packages/patches/calibre-remove-test-unrar.patch: New file.
* gnu/packages/ebook.scm (calibre)[source]: Use it.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
This commit is contained in:
Brendan Tildesley 2019-05-05 14:04:02 +02:00 committed by Danny Milosavljevic
parent c187c9d786
commit 15871b4087
No known key found for this signature in database
GPG Key ID: E71A35542C30BAA5
3 changed files with 31 additions and 1 deletions

View File

@ -690,6 +690,7 @@ dist_patch_DATA = \
%D%/packages/patches/boost-fix-icu-build.patch \
%D%/packages/patches/byobu-writable-status.patch \
%D%/packages/patches/calibre-no-updates-dialog.patch \
%D%/packages/patches/calibre-remove-test-unrar.patch \
%D%/packages/patches/casync-renameat2-declaration.patch \
%D%/packages/patches/catdoc-CVE-2017-11110.patch \
%D%/packages/patches/cdparanoia-fpic.patch \

View File

@ -96,7 +96,8 @@
'(begin
(delete-file "src/odf/thumbnail.py")
#t))
(patches (search-patches "calibre-no-updates-dialog.patch"))))
(patches (search-patches "calibre-no-updates-dialog.patch"
"calibre-remove-test-unrar.patch"))))
(build-system python-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)

View File

@ -0,0 +1,28 @@
Unrar contains security vulnerabilities and has thus been removed from Guix.
From a16f97b02bd8afd0ec05c471e156f631f2cc6eec Mon Sep 17 00:00:00 2001
From: Brendan Tildesley <mail@brendan.scot>
Date: Tue, 26 Mar 2019 22:17:03 +1100
Subject: [PATCH] Remove test_unrar.
---
src/calibre/test_build.py | 4 ----
1 file changed, 4 deletions(-)
diff --git a/src/calibre/test_build.py b/src/calibre/test_build.py
index d67afd20a6..709132ef17 100644
--- a/src/calibre/test_build.py
+++ b/src/calibre/test_build.py
@@ -220,10 +220,6 @@ class BuildTest(unittest.TestCase):
from calibre.gui2.win_file_dialogs import test
test()
- def test_unrar(self):
- from calibre.utils.unrar import test_basic
- test_basic()
-
@unittest.skipUnless(iswindows, 'WPD is windows only')
def test_wpd(self):
wpd = plugins['wpd'][0]
--
2.21.0