gnu: ghc-haddock-library: Update to 1.7.0.

The new source tarball does not have bundled dependencies, so it does
not need to be patched.

* gnu/packages/haskell-xyz.scm (ghc-haddock-library): Update to 1.7.0.
[source]: Remove 'patches', 'modules' and 'snippet'.
[arguments]: Update the 'relax-test-suite-dependencies' phase to allow
newer versions of 'hspec' and 'QuickCheck'; remove the
'add-examples-directory' phase.
* gnu/packages/patches/ghc-haddock-library-unbundle.patch: Delete file.
* gnu/local.mk: Remove it.
This commit is contained in:
Timothy Sample 2019-10-31 13:33:24 -04:00
parent 1e0db876d1
commit 10707d5720
No known key found for this signature in database
GPG key ID: 2AC6A5EC1C357C59
3 changed files with 6 additions and 104 deletions

View file

@ -880,7 +880,6 @@ dist_patch_DATA = \
%D%/packages/patches/ghc-8.0-fall-back-to-madv_dontneed.patch \
%D%/packages/patches/ghc-diff-swap-cover-args.patch \
%D%/packages/patches/ghc-dont-pass-linker-flags-via-response-files.patch \
%D%/packages/patches/ghc-haddock-library-unbundle.patch \
%D%/packages/patches/ghc-hpack-fix-tests.patch \
%D%/packages/patches/ghc-monad-par-fix-tests.patch \
%D%/packages/patches/ghostscript-no-header-id.patch \

View file

@ -4328,7 +4328,7 @@ (define-public ghc-haddock-api
(define-public ghc-haddock-library
(package
(name "ghc-haddock-library")
(version "1.5.0.1")
(version "1.7.0")
(source
(origin
(method url-fetch)
@ -4338,29 +4338,18 @@ (define-public ghc-haddock-library
".tar.gz"))
(sha256
(base32
"1cmbg8l5xrwpliclwy3l057raypjqy0hsg1h1743ahaj8gq10b7z"))
(patches (search-patches
"ghc-haddock-library-unbundle.patch"))
(modules '((guix build utils)))
(snippet '(begin
(delete-file-recursively "vendor")
#t))))
"04fhcjk0pvsaqvsgp2w06cv2qvshq1xs1bwc157q4lmkgr57khp7"))))
(build-system haskell-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
;; Since there is no revised Cabal file upstream, we have to
;; patch it manually.
(add-before 'configure 'relax-test-suite-dependencies
(lambda _
(substitute* "haddock-library.cabal"
(("base-compat\\s*\\^>= 0\\.9\\.3") "base-compat")
(("hspec\\s*\\^>= 2\\.4\\.4") "hspec"))))
;; The release tarball does not contain the "fixtures/examples"
;; directory, which is required for testing. In the upstream
;; repository, the directory exists and is populated. Here, we
;; create an empty directory to placate the tests.
(add-before 'check 'add-examples-directory
(lambda _
(mkdir "fixtures/examples")
(("hspec\\s*>= 2.4.4 && < 2.6") "hspec")
(("QuickCheck\\s*\\^>= 2.11") "QuickCheck"))
#t)))))
(native-inputs
`(("ghc-base-compat" ,ghc-base-compat)

View file

@ -1,86 +0,0 @@
This patch (inspired by Debian) allows ghc-haddock-library to use our
ghc-attoparsec package instead of using a bundled version.
--- a/haddock-library.cabal 2018-09-01 01:22:18.676855884 -0400
+++ b/haddock-library.cabal 2018-09-01 01:25:10.501150260 -0400
@@ -10,7 +10,6 @@
itself, see the haddock package.
license: BSD3
license-files: LICENSE
- vendor/attoparsec-0.13.1.0/LICENSE
maintainer: Alex Biehl <alexbiehl@gmail.com>, Simon Hengel <sol@typeful.net>, Mateusz Kowalczyk <fuuzetsu@fuuzetsu.co.uk>
homepage: http://www.haskell.org/haddock/
bug-reports: https://github.com/haskell/haddock/issues
@@ -28,7 +27,6 @@
, containers >= 0.4.2.1 && < 0.6
, transformers >= 0.3.0 && < 0.6
- -- internal sub-lib
build-depends: attoparsec
hs-source-dirs: src
@@ -49,42 +47,6 @@
if impl(ghc >= 8.0)
ghc-options: -Wcompat -Wnoncanonical-monad-instances -Wnoncanonical-monadfail-instances
-library attoparsec
- default-language: Haskell2010
-
- build-depends:
- base >= 4.5 && < 4.12
- , bytestring >= 0.9.2.1 && < 0.11
- , deepseq >= 1.3 && < 1.5
-
- hs-source-dirs: vendor/attoparsec-0.13.1.0
-
- -- NB: haddock-library needs only small part of lib:attoparsec
- -- internally, so we only bundle that subset here
- exposed-modules:
- Data.Attoparsec.ByteString
- Data.Attoparsec.ByteString.Char8
- Data.Attoparsec.Combinator
-
- other-modules:
- Data.Attoparsec
- Data.Attoparsec.ByteString.Buffer
- Data.Attoparsec.ByteString.FastSet
- Data.Attoparsec.ByteString.Internal
- Data.Attoparsec.Internal
- Data.Attoparsec.Internal.Fhthagn
- Data.Attoparsec.Internal.Types
- Data.Attoparsec.Number
-
- ghc-options: -funbox-strict-fields -Wall -fwarn-tabs -O2
-
- ghc-options: -Wall
- if impl(ghc >= 8.0)
- ghc-options: -Wcompat -Wnoncanonical-monad-instances -Wnoncanonical-monadfail-instances
- else
- build-depends: semigroups ^>= 0.18.3, fail ^>= 4.9.0.0
-
-
test-suite spec
type: exitcode-stdio-1.0
default-language: Haskell2010
@@ -115,11 +77,10 @@
, hspec ^>= 2.4.4
, QuickCheck ^>= 2.11
- -- internal sub-lib
build-depends: attoparsec
-- Versions for the dependencies below are transitively pinned by
- -- dependency on haddock-library:lib:attoparsec
+ -- dependency on attoparsec
build-depends:
base
, bytestring
@@ -146,7 +107,7 @@
haddock-library
-- Versions for the dependencies below are transitively pinned by
- -- dependency on haddock-library:lib:attoparsec
+ -- dependency on attoparsec
build-depends:
base