gnu: python-shiboken-2: Fix compilation with Python 3.10.

* gnu/packages/patches/python-shiboken-2-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/qt.scm (python-shiboken-2): Use it.
This commit is contained in:
Ludovic Courtès 2023-04-19 23:21:46 +02:00
parent 3d1b93db65
commit 0e2e7c7554
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
3 changed files with 20 additions and 2 deletions

View file

@ -1667,6 +1667,7 @@ dist_patch_DATA = \
%D%/packages/patches/python-pypdf-annotate-tests-appropriately.patch \
%D%/packages/patches/python-sip-include-dirs.patch \
%D%/packages/patches/python-sgmllib3k-assertions.patch \
%D%/packages/patches/python-shiboken-2-compat.patch \
%D%/packages/patches/python-telingo-fix-comparison.patch \
%D%/packages/patches/python-typeguard-python3.10.patch \
%D%/packages/patches/python-w3lib-fix-test-failure.patch \

View file

@ -0,0 +1,16 @@
Provide a declaration that's missing in Python 3.10.
--- pyside-setup-opensource-src-5.15.8/sources/shiboken2/libshiboken/sbkpython.h 2023-04-19 23:14:11.415337435 +0200
+++ pyside-setup-opensource-src-5.15.8/sources/shiboken2/libshiboken/sbkpython.h 2023-04-19 23:18:09.055605606 +0200
@@ -108,6 +108,11 @@ extern "C" {
#if PY_MAJOR_VERSION >= 3
#define IS_PY3K
+extern "C" {
+ /* In Python 3.10 this declaration is not provided by <Python.h>. */
+ extern PyObject* _Py_Mangle(PyObject *p, PyObject *name);
+}
+
#define PyInt_Type PyLong_Type
#define PyInt_Check PyLong_Check
#define PyInt_CheckExact PyLong_CheckExact

View file

@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2023 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2018, 2019, 2020, 2021, 2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
@ -3921,7 +3921,8 @@ (define-public python-shiboken-2
version ".tar.xz"))
(sha256
(base32
"0pbbdypwkn3vrgy8ww207fl8pqq4jv80bck9qz5v9dfyr0166hr3"))))
"0pbbdypwkn3vrgy8ww207fl8pqq4jv80bck9qz5v9dfyr0166hr3"))
(patches (search-patches "python-shiboken-2-compat.patch"))))
(build-system cmake-build-system)
(inputs
(list clang-toolchain