gnu: gcr: Update to 3.28.0.
* gnu/packages/patches/gcr-disable-failing-tests.patch, gnu/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch: Remove files. * gnu/local.mk (dist_patch_DATA): Remove patches. * gnu/packages/gnome.scm (gcr): Update to 3.28.0. [arguments]: Add phase "disable-failing-tests"; rewrite "pre-check" phase. [native-inputs]: Add libxml2.
This commit is contained in:
parent
9863ce205d
commit
0daf0efbe6
4 changed files with 26 additions and 178 deletions
|
@ -794,8 +794,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gcc-6-source-date-epoch-1.patch \
|
||||
%D%/packages/patches/gcc-6-source-date-epoch-2.patch \
|
||||
%D%/packages/patches/gcc-8-strmov-store-file-names.patch \
|
||||
%D%/packages/patches/gcr-disable-failing-tests.patch \
|
||||
%D%/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch \
|
||||
%D%/packages/patches/gd-CVE-2018-5711.patch \
|
||||
%D%/packages/patches/gd-CVE-2018-1000222.patch \
|
||||
%D%/packages/patches/gd-CVE-2019-6977.patch \
|
||||
|
|
|
@ -587,36 +587,43 @@ (define-public gnome-disk-utility
|
|||
(define-public gcr
|
||||
(package
|
||||
(name "gcr")
|
||||
(version "3.20.0")
|
||||
(version "3.28.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnome/sources/" name "/"
|
||||
(version-major+minor version) "/"
|
||||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0ydk9dzxx6snxza7j5ps8x932hbr3x1b8hhcaqjq4w4admi2qmwh"))
|
||||
(patches
|
||||
(search-patches "gcr-disable-failing-tests.patch"
|
||||
"gcr-fix-collection-tests-to-work-with-gpg-21.patch"))))
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnome/sources/" name "/"
|
||||
(version-major+minor version) "/"
|
||||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"02xgky22xgvhgd525khqh64l5i21ca839fj9jzaqdi3yvb8pbq8m"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:phases (modify-phases %standard-phases
|
||||
(add-before
|
||||
'check 'pre-check
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
(substitute* "build/tap-driver"
|
||||
(("/usr/bin/env python") (which "python"))))))))
|
||||
'(#:phases
|
||||
(modify-phases %standard-phases
|
||||
;; These fail because /var/lib/dbus/machine-id is not present in the
|
||||
;; build environment.
|
||||
(add-after 'unpack 'disable-failing-tests
|
||||
(lambda _
|
||||
(substitute* "gcr/test-system-prompt.c"
|
||||
(("g_test_add") "//")
|
||||
(("return.*") "return 0;"))
|
||||
#t))
|
||||
(add-before 'check 'pre-check
|
||||
(lambda _
|
||||
;; Some tests expect to write to $HOME.
|
||||
(setenv "HOME" "/tmp")
|
||||
#t)))))
|
||||
(inputs
|
||||
`(("dbus" ,dbus)
|
||||
("gnupg" ,gnupg) ;called as a child process during tests
|
||||
("gnupg" ,gnupg) ;called as a child process during tests
|
||||
("libgcrypt" ,libgcrypt)))
|
||||
(native-inputs
|
||||
`(("python" ,python-2) ;for tests
|
||||
`(("python" ,python-2) ;for tests
|
||||
("pkg-config" ,pkg-config)
|
||||
("glib" ,glib "bin")
|
||||
("gobject-introspection" ,gobject-introspection)
|
||||
("intltool" ,intltool)
|
||||
("libxml2" ,libxml2)
|
||||
("xsltproc" ,libxslt)))
|
||||
;; mentioned in gck.pc, gcr.pc and gcr-ui.pc
|
||||
(propagated-inputs
|
||||
|
|
|
@ -1,126 +0,0 @@
|
|||
This patch removes a group of tests that fail because /var/lib/dbus/machine-id
|
||||
is not present in the build environment.
|
||||
|
||||
--- gcr-3.20.0.old/Makefile.in 2017-07-03 18:05:10.742595317 -0400
|
||||
+++ gcr-3.20.0/Makefile.in 2017-07-03 18:08:26.379565428 -0400
|
||||
@@ -482,8 +482,7 @@
|
||||
test-openssh$(EXEEXT) test-secure-memory$(EXEEXT) \
|
||||
test-trust$(EXEEXT) test-parser$(EXEEXT) test-record$(EXEEXT) \
|
||||
test-memory-icon$(EXEEXT) test-gnupg-key$(EXEEXT) \
|
||||
- test-gnupg-collection$(EXEEXT) test-gnupg-process$(EXEEXT) \
|
||||
- test-system-prompt$(EXEEXT)
|
||||
+ test-gnupg-collection$(EXEEXT) test-gnupg-process$(EXEEXT)
|
||||
@WITH_GTK_TRUE@am__EXEEXT_4 = frob-certificate$(EXEEXT) \
|
||||
@WITH_GTK_TRUE@ frob-combo-selector$(EXEEXT) \
|
||||
@WITH_GTK_TRUE@ frob-gnupg-selector$(EXEEXT) \
|
||||
@@ -882,14 +881,6 @@
|
||||
am_test_symkey_OBJECTS = egg/test-symkey.$(OBJEXT)
|
||||
test_symkey_OBJECTS = $(am_test_symkey_OBJECTS)
|
||||
test_symkey_DEPENDENCIES = $(am__DEPENDENCIES_4)
|
||||
-am_test_system_prompt_OBJECTS = \
|
||||
- gcr/test_system_prompt-test-system-prompt.$(OBJEXT)
|
||||
-test_system_prompt_OBJECTS = $(am_test_system_prompt_OBJECTS)
|
||||
-test_system_prompt_DEPENDENCIES = $(am__DEPENDENCIES_3)
|
||||
-test_system_prompt_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC \
|
||||
- $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link $(CCLD) \
|
||||
- $(test_system_prompt_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) \
|
||||
- $(LDFLAGS) -o $@
|
||||
am_test_trust_OBJECTS = gcr/test_trust-test-trust.$(OBJEXT)
|
||||
test_trust_OBJECTS = $(am_test_trust_OBJECTS)
|
||||
test_trust_DEPENDENCIES = $(am__DEPENDENCIES_3)
|
||||
@@ -974,8 +965,7 @@
|
||||
$(test_secret_exchange_SOURCES) $(test_secure_memory_SOURCES) \
|
||||
$(test_simple_certificate_SOURCES) \
|
||||
$(test_subject_public_key_SOURCES) $(test_symkey_SOURCES) \
|
||||
- $(test_system_prompt_SOURCES) $(test_trust_SOURCES) \
|
||||
- $(test_util_SOURCES)
|
||||
+ $(test_trust_SOURCES) $(test_util_SOURCES)
|
||||
DIST_SOURCES = $(libegg_asn1x_la_SOURCES) $(libegg_hex_la_SOURCES) \
|
||||
$(libegg_secmem_la_SOURCES) $(libegg_test_la_SOURCES) \
|
||||
$(libegg_la_SOURCES) $(libgck_@GCK_MAJOR@_la_SOURCES) \
|
||||
@@ -1016,8 +1006,7 @@
|
||||
$(test_secret_exchange_SOURCES) $(test_secure_memory_SOURCES) \
|
||||
$(test_simple_certificate_SOURCES) \
|
||||
$(test_subject_public_key_SOURCES) $(test_symkey_SOURCES) \
|
||||
- $(test_system_prompt_SOURCES) $(test_trust_SOURCES) \
|
||||
- $(test_util_SOURCES)
|
||||
+ $(test_trust_SOURCES) $(test_util_SOURCES)
|
||||
RECURSIVE_TARGETS = all-recursive check-recursive cscopelist-recursive \
|
||||
ctags-recursive dvi-recursive html-recursive info-recursive \
|
||||
install-data-recursive install-dvi-recursive \
|
||||
@@ -2117,8 +2106,7 @@
|
||||
test-memory-icon \
|
||||
test-gnupg-key \
|
||||
test-gnupg-collection \
|
||||
- test-gnupg-process \
|
||||
- test-system-prompt
|
||||
+ test-gnupg-process
|
||||
|
||||
test_certificate_SOURCES = gcr/test-certificate.c
|
||||
test_certificate_CFLAGS = $(gcr_CFLAGS)
|
||||
@@ -2171,9 +2159,6 @@
|
||||
test_subject_public_key_SOURCES = gcr/test-subject-public-key.c
|
||||
test_subject_public_key_CFLAGS = $(gcr_CFLAGS)
|
||||
test_subject_public_key_LDADD = $(gcr_LIBS)
|
||||
-test_system_prompt_SOURCES = gcr/test-system-prompt.c
|
||||
-test_system_prompt_CFLAGS = $(gcr_CFLAGS)
|
||||
-test_system_prompt_LDADD = $(gcr_LIBS)
|
||||
test_trust_SOURCES = gcr/test-trust.c
|
||||
test_trust_CFLAGS = $(gcr_CFLAGS)
|
||||
test_trust_LDADD = $(gcr_LIBS)
|
||||
@@ -3283,12 +3268,6 @@
|
||||
test-symkey$(EXEEXT): $(test_symkey_OBJECTS) $(test_symkey_DEPENDENCIES) $(EXTRA_test_symkey_DEPENDENCIES)
|
||||
@rm -f test-symkey$(EXEEXT)
|
||||
$(AM_V_CCLD)$(LINK) $(test_symkey_OBJECTS) $(test_symkey_LDADD) $(LIBS)
|
||||
-gcr/test_system_prompt-test-system-prompt.$(OBJEXT): \
|
||||
- gcr/$(am__dirstamp) gcr/$(DEPDIR)/$(am__dirstamp)
|
||||
-
|
||||
-test-system-prompt$(EXEEXT): $(test_system_prompt_OBJECTS) $(test_system_prompt_DEPENDENCIES) $(EXTRA_test_system_prompt_DEPENDENCIES)
|
||||
- @rm -f test-system-prompt$(EXEEXT)
|
||||
- $(AM_V_CCLD)$(test_system_prompt_LINK) $(test_system_prompt_OBJECTS) $(test_system_prompt_LDADD) $(LIBS)
|
||||
gcr/test_trust-test-trust.$(OBJEXT): gcr/$(am__dirstamp) \
|
||||
gcr/$(DEPDIR)/$(am__dirstamp)
|
||||
|
||||
@@ -3446,7 +3425,6 @@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@gcr/$(DEPDIR)/test_secure_memory-test-secure-memory.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@gcr/$(DEPDIR)/test_simple_certificate-test-simple-certificate.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@gcr/$(DEPDIR)/test_subject_public_key-test-subject-public-key.Po@am__quote@
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@gcr/$(DEPDIR)/test_system_prompt-test-system-prompt.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@gcr/$(DEPDIR)/test_trust-test-trust.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@gcr/$(DEPDIR)/test_util-test-util.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@ui/$(DEPDIR)/frob_certificate-frob-certificate.Po@am__quote@
|
||||
@@ -4968,20 +4946,6 @@
|
||||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
||||
@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(test_subject_public_key_CFLAGS) $(CFLAGS) -c -o gcr/test_subject_public_key-test-subject-public-key.obj `if test -f 'gcr/test-subject-public-key.c'; then $(CYGPATH_W) 'gcr/test-subject-public-key.c'; else $(CYGPATH_W) '$(srcdir)/gcr/test-subject-public-key.c'; fi`
|
||||
|
||||
-gcr/test_system_prompt-test-system-prompt.o: gcr/test-system-prompt.c
|
||||
-@am__fastdepCC_TRUE@ $(AM_V_CC)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(test_system_prompt_CFLAGS) $(CFLAGS) -MT gcr/test_system_prompt-test-system-prompt.o -MD -MP -MF gcr/$(DEPDIR)/test_system_prompt-test-system-prompt.Tpo -c -o gcr/test_system_prompt-test-system-prompt.o `test -f 'gcr/test-system-prompt.c' || echo '$(srcdir)/'`gcr/test-system-prompt.c
|
||||
-@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) gcr/$(DEPDIR)/test_system_prompt-test-system-prompt.Tpo gcr/$(DEPDIR)/test_system_prompt-test-system-prompt.Po
|
||||
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='gcr/test-system-prompt.c' object='gcr/test_system_prompt-test-system-prompt.o' libtool=no @AMDEPBACKSLASH@
|
||||
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
||||
-@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(test_system_prompt_CFLAGS) $(CFLAGS) -c -o gcr/test_system_prompt-test-system-prompt.o `test -f 'gcr/test-system-prompt.c' || echo '$(srcdir)/'`gcr/test-system-prompt.c
|
||||
-
|
||||
-gcr/test_system_prompt-test-system-prompt.obj: gcr/test-system-prompt.c
|
||||
-@am__fastdepCC_TRUE@ $(AM_V_CC)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(test_system_prompt_CFLAGS) $(CFLAGS) -MT gcr/test_system_prompt-test-system-prompt.obj -MD -MP -MF gcr/$(DEPDIR)/test_system_prompt-test-system-prompt.Tpo -c -o gcr/test_system_prompt-test-system-prompt.obj `if test -f 'gcr/test-system-prompt.c'; then $(CYGPATH_W) 'gcr/test-system-prompt.c'; else $(CYGPATH_W) '$(srcdir)/gcr/test-system-prompt.c'; fi`
|
||||
-@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) gcr/$(DEPDIR)/test_system_prompt-test-system-prompt.Tpo gcr/$(DEPDIR)/test_system_prompt-test-system-prompt.Po
|
||||
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='gcr/test-system-prompt.c' object='gcr/test_system_prompt-test-system-prompt.obj' libtool=no @AMDEPBACKSLASH@
|
||||
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
||||
-@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(test_system_prompt_CFLAGS) $(CFLAGS) -c -o gcr/test_system_prompt-test-system-prompt.obj `if test -f 'gcr/test-system-prompt.c'; then $(CYGPATH_W) 'gcr/test-system-prompt.c'; else $(CYGPATH_W) '$(srcdir)/gcr/test-system-prompt.c'; fi`
|
||||
-
|
||||
gcr/test_trust-test-trust.o: gcr/test-trust.c
|
||||
@am__fastdepCC_TRUE@ $(AM_V_CC)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(test_trust_CFLAGS) $(CFLAGS) -MT gcr/test_trust-test-trust.o -MD -MP -MF gcr/$(DEPDIR)/test_trust-test-trust.Tpo -c -o gcr/test_trust-test-trust.o `test -f 'gcr/test-trust.c' || echo '$(srcdir)/'`gcr/test-trust.c
|
||||
@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) gcr/$(DEPDIR)/test_trust-test-trust.Tpo gcr/$(DEPDIR)/test_trust-test-trust.Po
|
||||
@@ -5808,13 +5772,6 @@
|
||||
$(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
|
||||
--log-file $$b.log --trs-file $$b.trs \
|
||||
$(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
|
||||
- "$$tst" $(AM_TESTS_FD_REDIRECT)
|
||||
-test-system-prompt.log: test-system-prompt$(EXEEXT)
|
||||
- @p='test-system-prompt$(EXEEXT)'; \
|
||||
- b='test-system-prompt'; \
|
||||
- $(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
|
||||
- --log-file $$b.log --trs-file $$b.trs \
|
||||
- $(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
|
||||
"$$tst" $(AM_TESTS_FD_REDIRECT)
|
||||
.test.log:
|
||||
@p='$<'; \
|
|
@ -1,31 +0,0 @@
|
|||
This patch comes from Debian.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=771052
|
||||
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=835737
|
||||
|
||||
--- gcr-3.20.0.old/gcr/test-gnupg-collection.c 2017-06-29 14:26:33.810838197 -0400
|
||||
+++ gcr-3.20.0/gcr/test-gnupg-collection.c 2017-06-30 17:25:09.149383067 -0400
|
||||
@@ -115,6 +115,14 @@
|
||||
|
||||
g_object_unref (test->collection);
|
||||
|
||||
+ /* remove potential gpg 2.1 extras, ignore any errors. */
|
||||
+ cmd = g_strdup_printf ("rm -rf %s/*.d", test->directory);
|
||||
+ system(cmd);
|
||||
+ g_free(cmd);
|
||||
+ cmd = g_strdup_printf ("rm -f %s/.gpg-v21-migrated", test->directory);
|
||||
+ system(cmd);
|
||||
+ g_free(cmd);
|
||||
+
|
||||
cmd = g_strdup_printf ("rm -f %s/*", test->directory);
|
||||
g_spawn_check_exit_status (system (cmd), &error);
|
||||
g_assert_no_error (error);
|
||||
@@ -202,7 +210,7 @@
|
||||
GcrGnupgKey *key;
|
||||
|
||||
_gcr_gnupg_collection_load_async (test->collection, NULL, on_async_ready, test);
|
||||
- egg_test_wait_until (500);
|
||||
+ egg_test_wait_until (2500);
|
||||
g_assert (test->result);
|
||||
_gcr_gnupg_collection_load_finish (test->collection, test->result, &error);
|
||||
g_assert_no_error (error);
|
Loading…
Reference in a new issue