gnu: procps: Update to 3.3.11.

procps-ng is the new upstream.

* gnu/packages/procps.scm (procps): Update to 3.3.11.
  [source]: Adjust formatting.  Remove patches.
  [home-page]: Update URL.
* gnu/packages/patches/procps-make-3.82.patch: Remove file.
* gnu-system.am (dist_patch_DATA): Remove it.
This commit is contained in:
宋文武 2015-09-16 21:17:43 +08:00
parent b85d098410
commit 0cc2284819
3 changed files with 21 additions and 64 deletions

View file

@ -603,7 +603,6 @@ dist_patch_DATA = \
gnu/packages/patches/portaudio-audacity-compat.patch \ gnu/packages/patches/portaudio-audacity-compat.patch \
gnu/packages/patches/preseq-1.0.2-install-to-PREFIX.patch \ gnu/packages/patches/preseq-1.0.2-install-to-PREFIX.patch \
gnu/packages/patches/preseq-1.0.2-link-with-libbam.patch \ gnu/packages/patches/preseq-1.0.2-link-with-libbam.patch \
gnu/packages/patches/procps-make-3.82.patch \
gnu/packages/patches/pt-scotch-build-parallelism.patch \ gnu/packages/patches/pt-scotch-build-parallelism.patch \
gnu/packages/patches/pulseaudio-fix-mult-test.patch \ gnu/packages/patches/pulseaudio-fix-mult-test.patch \
gnu/packages/patches/pulseaudio-longer-test-timeout.patch \ gnu/packages/patches/pulseaudio-longer-test-timeout.patch \

View file

@ -457,62 +457,34 @@ (define-public util-linux
(define-public procps (define-public procps
(package (package
(name "procps") (name "procps")
(version "3.2.8") (version "3.3.11")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
;; A mirror://sourceforge URI doesn't work, presumably becuase (uri (string-append "mirror://sourceforge/procps-ng/Production/"
;; the SourceForge project is misconfigured. "procps-ng-" version ".tar.xz"))
(uri (string-append "http://procps.sourceforge.net/procps-" (sha256
version ".tar.gz")) (base32
(sha256 "1va4n0mpsq327ca9dqp4hnrpgs6821rp0f2m0jyc1bfjl9lk2jg9"))))
(base32
"0d8mki0q4yamnkk4533kx8mc0jd879573srxhg6r2fs3lkc6iv8i"))
(patches (list (search-patch "procps-make-3.82.patch")))))
(build-system gnu-build-system) (build-system gnu-build-system)
(inputs `(("ncurses" ,ncurses)))
(arguments (arguments
'(#:modules ((guix build utils) '(#:modules ((guix build utils)
(guix build gnu-build-system) (guix build gnu-build-system)
(srfi srfi-1) (srfi srfi-1)
(srfi srfi-26)) (srfi srfi-26))
#:phases (alist-replace #:phases
'configure (modify-phases %standard-phases
(lambda* (#:key outputs #:allow-other-keys) (add-after
;; No `configure', just a single Makefile. 'install 'post-install
(let ((out (assoc-ref outputs "out"))) ;; Remove commands and man pages redudant with
(substitute* "Makefile" ;; Coreutils.
(("/usr/") "/") (lambda* (#:key outputs #:allow-other-keys)
(("--(owner|group) 0") "") (let* ((out (assoc-ref outputs "out"))
(("ldconfig") "true") (dup (append-map (cut find-files out <>)
(("^LDFLAGS[[:blank:]]*:=(.*)$" _ value) '("^kill" "^uptime"))))
;; Add libproc to the RPATH. (for-each delete-file dup)
(string-append "LDFLAGS := -Wl,-rpath=" #t))))))
out "/lib" value)))) (inputs `(("ncurses" ,ncurses)))
(setenv "CC" "gcc")) (home-page "https://gitlab.com/procps-ng/procps/")
(alist-replace
'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(and (zero?
(system* "make" "install"
(string-append "DESTDIR=" out)))
;; Remove commands and man pages redundant with
;; Coreutils.
(let ((dup (append-map (cut find-files out <>)
'("^kill" "^uptime"))))
(for-each delete-file dup)
#t)
;; Sanity check.
(zero?
(system* (string-append out "/bin/ps")
"--version")))))
%standard-phases))
;; What did you expect? Tests?
#:tests? #f))
(home-page "http://procps.sourceforge.net/")
(synopsis "Utilities that give information about processes") (synopsis "Utilities that give information about processes")
(description (description
"Procps is the package that has a bunch of small useful utilities "Procps is the package that has a bunch of small useful utilities

View file

@ -1,14 +0,0 @@
Fix compilation with GNU Make 3.82 (patch from Nixpkgs).
diff --git a/Makefile b/Makefile
index 09fb3ed..59eba16 100644
--- a/Makefile
+++ b/Makefile
@@ -174,7 +174,7 @@ INSTALL := $(BINFILES) $(MANFILES)
# want this rule first, use := on ALL, and ALL not filled in yet
all: do_all
--include */module.mk
+-include proc/module.mk ps/module.mk
do_all: $(ALL)