gnu: libwpd: Fix build with newer GCC.

* gnu/packages/patches/libwpd-gcc-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly
* gnu/packages/libreoffice.scm (libwpd)[source](patches): New field.
This commit is contained in:
Marius Bakke 2022-07-23 06:27:30 +02:00
parent cafb72db5d
commit 0c7cfbb82b
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
3 changed files with 19 additions and 0 deletions

View file

@ -1422,6 +1422,7 @@ dist_patch_DATA = \
%D%/packages/patches/libvpx-CVE-2016-2818.patch \
%D%/packages/patches/libxml2-xpath0-Add-option-xpath0.patch \
%D%/packages/patches/libxmlb-install-xb-tool-into-bindir.patch \
%D%/packages/patches/libwpd-gcc-compat.patch \
%D%/packages/patches/libxslt-generated-ids.patch \
%D%/packages/patches/libxt-guix-search-paths.patch \
%D%/packages/patches/lierolibre-check-unaligned-access.patch \

View file

@ -236,6 +236,7 @@ (define-public libwpd
(method url-fetch)
(uri (string-append "mirror://sourceforge/libwpd/libwpd/"
"libwpd-" version "/libwpd-" version ".tar.xz"))
(patches (search-patches "libwpd-gcc-compat.patch"))
(sha256 (base32
"02fx8bngslcj7i5g1gx2kiign4vp09wrmp5wpvix9igxcavb0r94"))))
(build-system gnu-build-system)

View file

@ -0,0 +1,17 @@
Fix build with newer GCC.
Taken from upstream:
https://sourceforge.net/p/libwpd/code/ci/333c8a26f231bea26ec3d56245315041bbf5577f/
--- a/src/lib/WPXTable.h
+++ b/src/lib/WPXTable.h
@@ -53,7 +53,7 @@
~WPXTable();
void insertRow();
void insertCell(unsigned char colSpan, unsigned char rowSpan, unsigned char borderBits);
- const WPXTableCell *getCell(size_t i, size_t j)
+ const WPXTableCell *getCell(std::size_t i, std::size_t j)
{
return &(m_tableRows[i])[j];
}